<!doctype html > <!--[if IE 8]><html class="ie8" lang="en"> <![endif]--> <!--[if IE 9]><html class="ie9" lang="en"> <![endif]--> <!--[if gt IE 8]><!--><html lang="en-US"> <!--<![endif]--><head><title>Kagame is giving more cash to the English Football Club, Arsenal, to wear a Rwanda logo on their shirt sleeves. | Therwandan</title><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1.0"><link rel="pingback" href="https://www.therwandan.com/xmlrpc.php" /><meta name='robots' content='max-image-preview:large' /> <script type="text/javascript" >function apbct_attach_event_handler__backend(elem, event, callback){                if(typeof window.addEventListener === "function") elem.addEventListener(event, callback);                else                                              elem.attachEvent(event, callback);            }            apbct_attach_event_handler__backend(window, 'load', function(){                ctSetCookie('ct_checkjs', 'b407e7b09d26635c54d5b7131e64f94db1e6de4db4654ccbbc79322f8b9a36dd' );            });</script><meta property="og:image" content="https://www.therwandan.com/wp-content/uploads/2021/08/kagame-arsenal.jpg" /><meta name="author" content="therwda"><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Therwandan &raquo; Feed" href="https://www.therwandan.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Therwandan &raquo; Comments Feed" href="https://www.therwandan.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Therwandan &raquo; Kagame is giving more cash to the English Football Club, Arsenal, to wear a Rwanda logo on their shirt sleeves. Comments Feed" href="https://www.therwandan.com/kagame-is-giving-more-cash-to-the-english-football-club-arsenal-to-wear-a-rwanda-logo-on-their-shirt-sleeves/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.therwandan.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style type="text/css">img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}</style><link rel='stylesheet' id='sb_instagram_styles-css'  href='https://www.therwandan.com/wp-content/plugins/instagram-feed/css/sbi-styles.min.css' type='text/css' media='all' /><link rel='stylesheet' id='wp-block-library-css'  href='https://www.therwandan.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' /><link rel='stylesheet' id='ye_dynamic-css'  href='https://www.therwandan.com/wp-content/plugins/youtube-embed/css/main.min.css' type='text/css' media='all' /><link crossorigin="anonymous" rel='stylesheet' id='google_font_open_sans-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C400%2C600%2C700&#038;ver=5.7.2' type='text/css' media='all' /><link crossorigin="anonymous" rel='stylesheet' id='google_font_roboto-css'  href='https://fonts.googleapis.com/css?family=Roboto%3A500%2C400italic%2C700%2C900%2C500italic%2C400%2C300&#038;ver=5.7.2' type='text/css' media='all' /><link rel='stylesheet' id='cookie-notice-front-css'  href='https://www.therwandan.com/wp-content/plugins/cookie-notice/includes/../css/front.min.css' type='text/css' media='all' /><link rel='stylesheet' id='__EPYT__style-css'  href='https://www.therwandan.com/wp-content/plugins/youtube-embed-plus/styles/ytprefs.min.css' type='text/css' media='all' /><style id='__EPYT__style-inline-css' type='text/css'>.epyt-gallery-thumb {
                        width: 33.333%;
                }</style><link rel='stylesheet' id='js_composer_front-css'  href='https://www.therwandan.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css' type='text/css' media='all' /><link rel='stylesheet' id='td-theme-css'  href='https://www.therwandan.com/wp-content/themes/Newspaperbk/style.css' type='text/css' media='all' /> <script type='text/javascript' src='https://www.therwandan.com/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script> <script type='text/javascript' src='https://www.therwandan.com/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script> <script type='text/javascript' id='ct_public_functions-js-extra'>var ctPublicFunctions = {"_ajax_nonce":"e2f004ee45","_rest_nonce":"3f919b9ca9","_ajax_url":"\/wp-admin\/admin-ajax.php","_rest_url":"https:\/\/www.therwandan.com\/wp-json\/","_apbct_ajax_url":"https:\/\/www.therwandan.com\/wp-content\/plugins\/cleantalk-spam-protect\/lib\/Cleantalk\/ApbctWP\/Ajax.php","data__set_cookies":"1","data__set_cookies__alt_sessions_type":"1"};</script> <script type='text/javascript' src='https://www.therwandan.com/wp-content/plugins/cleantalk-spam-protect/js/apbct-public--functions.min.js' id='ct_public_functions-js'></script> <script type='text/javascript' id='ct_public-js-extra'>var ctPublic = {"pixel__setting":"3","pixel__enabled":"1","pixel__url":"https:\/\/moderate8.cleantalk.org\/pixel\/2dfad595c9dc56b7a84ff9cddf389285.gif","data__email_check_before_post":"1"};</script> <script type='text/javascript' src='https://www.therwandan.com/wp-content/plugins/cleantalk-spam-protect/js/apbct-public.min.js' id='ct_public-js'></script> <script type='text/javascript' src='https://www.therwandan.com/wp-content/plugins/cleantalk-spam-protect/js/cleantalk-modal.min.js' id='cleantalk-modal-js'></script> <script type='text/javascript' id='ct_nocache-js-extra'>var ctNocache = {"ajaxurl":"\/wp-admin\/admin-ajax.php","info_flag":"","set_cookies_flag":"1","blog_home":"https:\/\/www.therwandan.com\/"};</script> <script type='text/javascript' src='https://www.therwandan.com/wp-content/plugins/cleantalk-spam-protect/js/cleantalk_nocache.min.js' id='ct_nocache-js'></script> <script type='text/javascript' id='cookie-notice-front-js-extra'>var cnArgs = {"ajaxUrl":"https:\/\/www.therwandan.com\/wp-admin\/admin-ajax.php","nonce":"5e3b40c876","hideEffect":"fade","position":"bottom","onScroll":"0","onScrollOffset":"100","onClick":"0","cookieName":"cookie_notice_accepted","cookieTime":"2592000","cookieTimeRejected":"2592000","cookiePath":"\/","cookieDomain":"","redirection":"0","cache":"1","refuse":"0","revokeCookies":"0","revokeCookiesOpt":"automatic","secure":"1"};</script> <script async type='text/javascript' src='https://www.therwandan.com/wp-content/plugins/cookie-notice/includes/../js/front.min.js' id='cookie-notice-front-js'></script> <script type='text/javascript' id='__ytprefs__-js-extra'>var _EPYT_ = {"ajaxurl":"https:\/\/www.therwandan.com\/wp-admin\/admin-ajax.php","security":"5d9dcf0d9a","gallery_scrolloffset":"20","eppathtoscripts":"https:\/\/www.therwandan.com\/wp-content\/plugins\/youtube-embed-plus\/scripts\/","eppath":"https:\/\/www.therwandan.com\/wp-content\/plugins\/youtube-embed-plus\/","epresponsiveselector":"[\"iframe.__youtube_prefs_widget__\"]","epdovol":"1","version":"13.4.2","evselector":"iframe.__youtube_prefs__[src], iframe[src*=\"youtube.com\/embed\/\"], iframe[src*=\"youtube-nocookie.com\/embed\/\"]","ajax_compat":"","ytapi_load":"light","pause_others":"","stopMobileBuffer":"1","vi_active":"","vi_js_posttypes":[]};</script> <script type='text/javascript' src='https://www.therwandan.com/wp-content/plugins/youtube-embed-plus/scripts/ytprefs.min.js' id='__ytprefs__-js'></script> <link rel="https://api.w.org/" href="https://www.therwandan.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.therwandan.com/wp-json/wp/v2/posts/16895" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.therwandan.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.therwandan.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.7.2" /><link rel="canonical" href="https://www.therwandan.com/kagame-is-giving-more-cash-to-the-english-football-club-arsenal-to-wear-a-rwanda-logo-on-their-shirt-sleeves/" /><link rel='shortlink' href='https://www.therwandan.com/?p=16895' /><link rel="alternate" type="application/json+oembed" href="https://www.therwandan.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.therwandan.com%2Fkagame-is-giving-more-cash-to-the-english-football-club-arsenal-to-wear-a-rwanda-logo-on-their-shirt-sleeves%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.therwandan.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.therwandan.com%2Fkagame-is-giving-more-cash-to-the-english-football-club-arsenal-to-wear-a-rwanda-logo-on-their-shirt-sleeves%2F&#038;format=xml" /> <script type="text/javascript">(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//www.therwandan.com/?wordfence_lh=1&hid=AA24C55FD871D6D58970211A1FFCAD14');</script><!--[if lt IE 9]><script src="https://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]--><meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/> <!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://www.therwandan.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="https://www.therwandan.com/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]--><style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style><link rel="amphtml" href="https://www.therwandan.com/kagame-is-giving-more-cash-to-the-english-football-club-arsenal-to-wear-a-rwanda-logo-on-their-shirt-sleeves/amp/">  <script>var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_animation_stack_effect="type0";
var tds_animation_stack=true;
var td_animation_stack_specific_selectors=".entry-thumb, img";
var td_animation_stack_general_selectors=".td-animation-stack img, .post img";
var td_ajax_url="https:\/\/www.therwandan.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=7.4";
var td_get_template_directory_uri="https:\/\/www.therwandan.com\/wp-content\/themes\/Newspaperbk";
var tds_snap_menu="smart_snap_mobile";
var tds_logo_on_sticky="show_header_logo";
var tds_header_style="11";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#4db2ec";
var tds_smart_sidebar="enabled";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";</script> <style>.td-header-wrap .td-header-top-menu-full,
    .td-header-wrap .top-header-menu .sub-menu {
        background-color: #3f83bf;
    }
    .td-header-style-8 .td-header-top-menu-full {
        background-color: transparent;
    }
    .td-header-style-8 .td-header-top-menu-full .td-header-top-menu {
        background-color: #3f83bf;
        padding-left: 15px;
        padding-right: 15px;
    }

    .td-header-wrap .td-header-top-menu-full .td-header-top-menu,
    .td-header-wrap .td-header-top-menu-full {
        border-bottom: none;
    }


    
    .td-header-top-menu,
    .td-header-top-menu a,
    .td-header-wrap .td-header-top-menu-full .td-header-top-menu,
    .td-header-wrap .td-header-top-menu-full a,
    .td-header-style-8 .td-header-top-menu,
    .td-header-style-8 .td-header-top-menu a {
        color: #ffffff;
    }

    
    .top-header-menu .current-menu-item > a,
    .top-header-menu .current-menu-ancestor > a,
    .top-header-menu .current-category-ancestor > a,
    .top-header-menu li a:hover {
        color: #ffffff;
    }

    
    .td-header-wrap .td-header-sp-top-widget .td-icon-font {
        color: #ffffff;
    }

    
    .td-header-wrap .td-header-sp-top-widget i.td-icon-font:hover {
        color: #ffffff;
    }


    
    .td-header-wrap .td-header-menu-wrap-full,
    .sf-menu > .current-menu-ancestor > a,
    .sf-menu > .current-category-ancestor > a,
    .td-header-menu-wrap.td-affix,
    .td-header-style-3 .td-header-main-menu,
    .td-header-style-3 .td-affix .td-header-main-menu,
    .td-header-style-4 .td-header-main-menu,
    .td-header-style-4 .td-affix .td-header-main-menu,
    .td-header-style-8 .td-header-menu-wrap.td-affix,
    .td-header-style-8 .td-header-top-menu-full {
		background-color: #e8f2ef;
    }


    .td-boxed-layout .td-header-style-3 .td-header-menu-wrap,
    .td-boxed-layout .td-header-style-4 .td-header-menu-wrap {
    	background-color: #e8f2ef !important;
    }


    @media (min-width: 1019px) {
        .td-header-style-1 .td-header-sp-recs,
        .td-header-style-1 .td-header-sp-logo {
            margin-bottom: 28px;
        }
    }

    @media (min-width: 768px) and (max-width: 1018px) {
        .td-header-style-1 .td-header-sp-recs,
        .td-header-style-1 .td-header-sp-logo {
            margin-bottom: 14px;
        }
    }

    .td-header-style-7 .td-header-top-menu {
        border-bottom: none;
    }


    
    .sf-menu ul .td-menu-item > a:hover,
    .sf-menu ul .sfHover > a,
    .sf-menu ul .current-menu-ancestor > a,
    .sf-menu ul .current-category-ancestor > a,
    .sf-menu ul .current-menu-item > a,
    .sf-menu > .current-menu-item > a:after,
    .sf-menu > .current-menu-ancestor > a:after,
    .sf-menu > .current-category-ancestor > a:after,
    .sf-menu > li:hover > a:after,
    .sf-menu > .sfHover > a:after,
    .td_block_mega_menu .td-next-prev-wrap a:hover,
    .td-mega-span .td-post-category:hover,
    .td-header-wrap .black-menu .sf-menu > li > a:hover,
    .td-header-wrap .black-menu .sf-menu > .current-menu-ancestor > a,
    .td-header-wrap .black-menu .sf-menu > .sfHover > a,
    .header-search-wrap .td-drop-down-search:after,
    .header-search-wrap .td-drop-down-search .btn:hover,
    .td-header-wrap .black-menu .sf-menu > .current-menu-item > a,
    .td-header-wrap .black-menu .sf-menu > .current-menu-ancestor > a,
    .td-header-wrap .black-menu .sf-menu > .current-category-ancestor > a {
        background-color: #dd0000;
    }


    .td_block_mega_menu .td-next-prev-wrap a:hover {
        border-color: #dd0000;
    }

    .header-search-wrap .td-drop-down-search:before {
        border-color: transparent transparent #dd0000 transparent;
    }

    .td_mega_menu_sub_cats .cur-sub-cat,
    .td_mod_mega_menu:hover .entry-title a {
        color: #dd0000;
    }


    
    .td-header-wrap .td-header-menu-wrap .sf-menu > li > a,
    .td-header-wrap .header-search-wrap .td-icon-search {
        color: #000000;
    }


    
    .td-footer-wrapper {
        background-color: #578fbf;
    }

    
    .td-sub-footer-container {
        background-color: #0066bf;
    }

    
    .top-header-menu > li > a,
    .td-weather-top-widget .td-weather-now .td-big-degrees,
    .td-weather-top-widget .td-weather-header .td-weather-city,
    .td-header-sp-top-menu .td_data_time {
        font-family:Tahoma, Verdana, Geneva;
	font-size:12px;
	font-weight:bold;
	text-transform:uppercase;
	
    }</style><link rel="icon" href="https://www.therwandan.com/wp-content/uploads/2016/10/therwandan1-1-150x150.png" sizes="32x32" /><link rel="icon" href="https://www.therwandan.com/wp-content/uploads/2016/10/therwandan1-1.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://www.therwandan.com/wp-content/uploads/2016/10/therwandan1-1.png" /><meta name="msapplication-TileImage" content="https://www.therwandan.com/wp-content/uploads/2016/10/therwandan1-1.png" />  <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', '', 'auto');
  ga('send', 'pageview');</script>  <noscript><style type="text/css">.wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head><body data-rsssl=1 class="post-template-default single single-post postid-16895 single-format-standard kagame-is-giving-more-cash-to-the-english-football-club-arsenal-to-wear-a-rwanda-logo-on-their-shirt-sleeves single_template_5 wpb-js-composer js-comp-ver-4.12.1 vc_responsive cookies-not-set td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage"><div class="td-scroll-up"><i class="td-icon-menu-up"></i></div><div class="td-menu-background"></div><div id="td-mobile-nav"><div class="td-mobile-container"><div class="td-menu-socials-wrap"><div class="td-menu-socials"></div><div class="td-mobile-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div></div><div class="td-mobile-content"><div class="menu-home-container"><ul id="menu-home" class="td-mobile-main-menu"><li id="menu-item-3042" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first menu-item-3042"><a href="https://www.therwandan.com">Home</a></li><li id="menu-item-3036" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-has-children menu-item-3036"><a href="https://www.therwandan.com/category/news/">News<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-0" class="menu-item-0"><a href="https://www.therwandan.com/category/news/africa/">Africa</a></li><li class="menu-item-0"><a href="https://www.therwandan.com/category/news/caricature/">CARTOON</a></li><li class="menu-item-0"><a href="https://www.therwandan.com/category/news/dont-miss/">Don&#8217;t Miss</a></li><li class="menu-item-0"><a href="https://www.therwandan.com/category/news/great-lakes/">Great lakes</a></li><li class="menu-item-0"><a href="https://www.therwandan.com/category/news/read-for-you/">Read for you</a></li><li class="menu-item-0"><a href="https://www.therwandan.com/category/news/rwanda/">Rwanda</a></li><li class="menu-item-0"><a href="https://www.therwandan.com/category/news/world/">World</a></li><li id="menu-item-10767" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10767"><a href="https://www.therwandan.com/category/news/caricature/">CARTOON</a></li></ul></li><li id="menu-item-3033" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-3033"><a href="https://www.therwandan.com/category/multimedia/">Multimedia<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li class="menu-item-0"><a href="https://www.therwandan.com/category/multimedia/photo/">Photo</a></li><li class="menu-item-0"><a href="https://www.therwandan.com/category/multimedia/video/">Video</a></li></ul></li><li id="menu-item-5943" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-5943"><a href="https://www.therwandan.com/category/country/">Country<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li class="menu-item-0"><a href="https://www.therwandan.com/category/country/economy/">Economy</a></li><li class="menu-item-0"><a href="https://www.therwandan.com/category/country/history/">History</a></li><li class="menu-item-0"><a href="https://www.therwandan.com/category/country/justice/">Justice</a></li><li class="menu-item-0"><a href="https://www.therwandan.com/category/country/lifestyle-country/">Life &amp; Society</a></li><li class="menu-item-0"><a href="https://www.therwandan.com/category/country/security/">Security</a></li></ul></li><li id="menu-item-3805" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3805"><a href="https://www.therwandan.com/category/analysis/">Analysis</a></li><li id="menu-item-5934" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5934"><a href="https://www.therwandan.com/category/opinion/">Opinion</a></li><li id="menu-item-3038" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-3038"><a href="https://www.therwandan.com/category/politics/">Politics<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li class="menu-item-0"><a href="https://www.therwandan.com/category/politics/events/">Events</a></li><li class="menu-item-0"><a href="https://www.therwandan.com/category/politics/politicians/">politicians</a></li><li class="menu-item-0"><a href="https://www.therwandan.com/category/politics/press-release/">Press Release</a></li></ul></li></ul></div></div></div></div><div class="td-search-background"></div><div class="td-search-wrap-mob"><div class="td-drop-down-search" aria-labelledby="td-header-search-button"><form method="get" class="td-search-form" action="https://www.therwandan.com/"><div class="td-search-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div><div role="search" class="td-search-input"> <span>Search</span> <input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" /></div></form><div id="td-aj-search-mob"></div></div></div><div id="td-outer-wrap"><div class="td-header-wrap td-header-style-11"><div class="td-header-top-menu-full"><div class="td-container td-header-row td-header-top-menu"><div class="top-bar-style-2"><div class="td-header-sp-top-menu"><div class="menu-top-container"><ul id="menu-menu-langues" class="top-header-menu"><li id="menu-item-5944" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-5944"><a href="https://www.therwandan.com/ki/">Kinyarwanda</a></li><li id="menu-item-5945" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-5945"><a href="https://www.therwandan.com/fr/">Francais</a></li><li id="menu-item-5946" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home td-menu-item td-normal-menu menu-item-5946"><a href="https://www.therwandan.com">English</a></li></ul></div></div></div><div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim"><div class="td-login-wrap"> <a href="#" class="td-back-button"><i class="td-icon-modal-back"></i></a><div id="td-login-div" class="td-login-form-div td-display-block"><div class="td-login-panel-title">Sign in</div><div class="td-login-panel-descr">Welcome! Log into your account</div><div class="td_display_err"></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email" value="" required><label>your username</label></div><div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" required><label>your password</label></div> <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login"><div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div></div><div id="td-forgot-pass-div" class="td-login-form-div td-display-none"><div class="td-login-panel-title">Password recovery</div><div class="td-login-panel-descr">Recover your password</div><div class="td_display_err"></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label>your email</label></div> <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password"><div class="td-login-info-text">A password will be e-mailed to you.</div></div></div></div></div></div><div class="td-header-menu-wrap-full"><div class="td-header-menu-wrap td-header-gradient"><div class="td-container td-header-row td-header-main-menu"><div id="td-header-menu" role="navigation"><div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div><div class="td-main-menu-logo td-logo-in-header"> <a class="td-mobile-logo td-sticky-header" href="https://www.therwandan.com/"> <img class="td-retina-data" data-retina="https://www.therwandan.com/wp-content/uploads/2021/05/logo-The-rwandan.png" src="https://www.therwandan.com/wp-content/uploads/2021/05/logo-The-rwandan.png" alt=""/> </a> <a class="td-header-logo td-sticky-header" href="https://www.therwandan.com/"> <img class="td-retina-data" data-retina="https://www.therwandan.com/wp-content/uploads/2021/05/logo-The-rwandan.png" src="https://www.therwandan.com/wp-content/uploads/2021/05/logo-The-rwandan.png" alt=""/> </a></div><div class="menu-home-container"><ul id="menu-home-1" class="sf-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-3042"><a href="https://www.therwandan.com">Home</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-mega-menu menu-item-3036"><a href="https://www.therwandan.com/category/news/">News</a><ul class="sub-menu"><li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_1_611ba787ec639_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_1_611ba787ec639" ><script>var block_td_uid_1_611ba787ec639 = new tdBlock();
block_td_uid_1_611ba787ec639.id = "td_uid_1_611ba787ec639";
block_td_uid_1_611ba787ec639.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"4","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_1_611ba787ec639_rand","el_class":"","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_1_611ba787ec639.td_column_number = "3";
block_td_uid_1_611ba787ec639.block_type = "td_block_mega_menu";
block_td_uid_1_611ba787ec639.post_count = "4";
block_td_uid_1_611ba787ec639.found_posts = "1950";
block_td_uid_1_611ba787ec639.header_color = "";
block_td_uid_1_611ba787ec639.ajax_pagination_infinite_stop = "";
block_td_uid_1_611ba787ec639.max_num_pages = "488";
tdBlocksArray.push(block_td_uid_1_611ba787ec639);</script> <script>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</script> <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_1_611ba787ec639" id="td_uid_2_611ba78815202" data-td_block_id="td_uid_1_611ba787ec639" data-td_filter_value="" href="https://www.therwandan.com/category/news/">All</a><a class="mega-menu-sub-cat-td_uid_1_611ba787ec639"  id="td_uid_3_611ba7881534b" data-td_block_id="td_uid_1_611ba787ec639" data-td_filter_value="10" href="https://www.therwandan.com/category/news/africa/">Africa</a><a class="mega-menu-sub-cat-td_uid_1_611ba787ec639"  id="td_uid_4_611ba788154a1" data-td_block_id="td_uid_1_611ba787ec639" data-td_filter_value="49" href="https://www.therwandan.com/category/news/caricature/">CARTOON</a><a class="mega-menu-sub-cat-td_uid_1_611ba787ec639"  id="td_uid_5_611ba788155e8" data-td_block_id="td_uid_1_611ba787ec639" data-td_filter_value="41" href="https://www.therwandan.com/category/news/dont-miss/">Don&#8217;t Miss</a><a class="mega-menu-sub-cat-td_uid_1_611ba787ec639"  id="td_uid_6_611ba78815734" data-td_block_id="td_uid_1_611ba787ec639" data-td_filter_value="22" href="https://www.therwandan.com/category/news/great-lakes/">Great lakes</a><a class="mega-menu-sub-cat-td_uid_1_611ba787ec639"  id="td_uid_7_611ba78815871" data-td_block_id="td_uid_1_611ba787ec639" data-td_filter_value="42" href="https://www.therwandan.com/category/news/read-for-you/">Read for you</a><a class="mega-menu-sub-cat-td_uid_1_611ba787ec639"  id="td_uid_8_611ba788159ae" data-td_block_id="td_uid_1_611ba787ec639" data-td_filter_value="20" href="https://www.therwandan.com/category/news/rwanda/">Rwanda</a><a class="mega-menu-sub-cat-td_uid_1_611ba787ec639"  id="td_uid_9_611ba78815af7" data-td_block_id="td_uid_1_611ba787ec639" data-td_filter_value="6" href="https://www.therwandan.com/category/news/world/">World</a></div></div><div id=td_uid_1_611ba787ec639 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span"><div class="td_module_mega_menu td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.therwandan.com/kagames-bromance-with-dr-congos-rulers-in-about-mineral-wealth-rwandas-gold-exports-are-skyrocketing/" rel="bookmark" title="Kagame’s Bromance with DR Congo’s Rulers in About Mineral Wealth – Rwanda’s Gold Exports Are Skyrocketing"><img width="218" height="150" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2019/12/Kagame-tshisekedi1-218x150.jpg" srcset="https://www.therwandan.com/wp-content/uploads/2019/12/Kagame-tshisekedi1-218x150.jpg 218w, https://www.therwandan.com/wp-content/uploads/2019/12/Kagame-tshisekedi1-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Kagame’s Bromance with DR Congo’s Rulers in About Mineral Wealth – Rwanda’s Gold Exports Are Skyrocketing"/></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/kagames-bromance-with-dr-congos-rulers-in-about-mineral-wealth-rwandas-gold-exports-are-skyrocketing/" rel="bookmark" title="Kagame’s Bromance with DR Congo’s Rulers in About Mineral Wealth – Rwanda’s Gold Exports Are Skyrocketing">Kagame’s Bromance with DR Congo’s Rulers in About Mineral Wealth –&#8230;</a></h3></div></div></div><div class="td-mega-span"><div class="td_module_mega_menu td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.therwandan.com/kagame-orders-the-english-football-club-arsenal-not-to-lose-games-%f0%9f%98%82/" rel="bookmark" title="Kagame Orders the English Football Club, Arsenal, Not to Lose Games &#x1f602;"><img width="218" height="150" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2018/05/President-Paul-Kagame...-218x150.jpg" srcset="https://www.therwandan.com/wp-content/uploads/2018/05/President-Paul-Kagame...-218x150.jpg 218w, https://www.therwandan.com/wp-content/uploads/2018/05/President-Paul-Kagame...-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Kagame Orders the English Football Club, Arsenal, Not to Lose Games &#x1f602;"/></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/kagame-orders-the-english-football-club-arsenal-not-to-lose-games-%f0%9f%98%82/" rel="bookmark" title="Kagame Orders the English Football Club, Arsenal, Not to Lose Games &#x1f602;">Kagame Orders the English Football Club, Arsenal, Not to Lose Games&#8230;</a></h3></div></div></div><div class="td-mega-span"><div class="td_module_mega_menu td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.therwandan.com/rwanda-and-mozambique-forces-pursue-rebels-after-port-city-recaptured/" rel="bookmark" title="Rwanda and Mozambique forces pursue rebels after port city recaptured"><img width="218" height="150" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2021/08/1111-218x150.jpg" srcset="https://www.therwandan.com/wp-content/uploads/2021/08/1111-218x150.jpg 218w, https://www.therwandan.com/wp-content/uploads/2021/08/1111-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Rwanda and Mozambique forces pursue rebels after port city recaptured"/></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/rwanda-and-mozambique-forces-pursue-rebels-after-port-city-recaptured/" rel="bookmark" title="Rwanda and Mozambique forces pursue rebels after port city recaptured">Rwanda and Mozambique forces pursue rebels after port city recaptured</a></h3></div></div></div><div class="td-mega-span"><div class="td_module_mega_menu td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.therwandan.com/kagame-dropped-the-covid19-testing-fee-to-us5-only-8-percent-of-the-12-9-million-rwandans-earn-more-than-us5-50-a-day/" rel="bookmark" title="Kagame dropped the Covid19 testing fee to US$5. Only 8 percent of the 12.9 million Rwandans earn more than US$5.50 a day."><img width="218" height="150" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2021/06/51239531757_0f5d3583f8_c-218x150.jpg" srcset="https://www.therwandan.com/wp-content/uploads/2021/06/51239531757_0f5d3583f8_c-218x150.jpg 218w, https://www.therwandan.com/wp-content/uploads/2021/06/51239531757_0f5d3583f8_c-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Kagame dropped the Covid19 testing fee to US$5. Only 8 percent of the 12.9 million Rwandans earn more than US$5.50 a day."/></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/kagame-dropped-the-covid19-testing-fee-to-us5-only-8-percent-of-the-12-9-million-rwandans-earn-more-than-us5-50-a-day/" rel="bookmark" title="Kagame dropped the Covid19 testing fee to US$5. Only 8 percent of the 12.9 million Rwandans earn more than US$5.50 a day.">Kagame dropped the Covid19 testing fee to US$5. Only 8 percent&#8230;</a></h3></div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_611ba787ec639" data-td_block_id="td_uid_1_611ba787ec639"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_1_611ba787ec639" data-td_block_id="td_uid_1_611ba787ec639"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div></div></div></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-10767"><a href="https://www.therwandan.com/category/news/caricature/">CARTOON</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-3033"><a href="https://www.therwandan.com/category/multimedia/">Multimedia</a><ul class="sub-menu"><li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_10_611ba78850d8d_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_10_611ba78850d8d" ><script>var block_td_uid_10_611ba78850d8d = new tdBlock();
block_td_uid_10_611ba78850d8d.id = "td_uid_10_611ba78850d8d";
block_td_uid_10_611ba78850d8d.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"21","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_10_611ba78850d8d_rand","el_class":"","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_10_611ba78850d8d.td_column_number = "3";
block_td_uid_10_611ba78850d8d.block_type = "td_block_mega_menu";
block_td_uid_10_611ba78850d8d.post_count = "4";
block_td_uid_10_611ba78850d8d.found_posts = "79";
block_td_uid_10_611ba78850d8d.header_color = "";
block_td_uid_10_611ba78850d8d.ajax_pagination_infinite_stop = "";
block_td_uid_10_611ba78850d8d.max_num_pages = "20";
tdBlocksArray.push(block_td_uid_10_611ba78850d8d);</script> <script>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</script> <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_10_611ba78850d8d" id="td_uid_11_611ba7885336c" data-td_block_id="td_uid_10_611ba78850d8d" data-td_filter_value="" href="https://www.therwandan.com/category/multimedia/">All</a><a class="mega-menu-sub-cat-td_uid_10_611ba78850d8d"  id="td_uid_12_611ba788534b2" data-td_block_id="td_uid_10_611ba78850d8d" data-td_filter_value="25" href="https://www.therwandan.com/category/multimedia/photo/">Photo</a><a class="mega-menu-sub-cat-td_uid_10_611ba78850d8d"  id="td_uid_13_611ba788535fc" data-td_block_id="td_uid_10_611ba78850d8d" data-td_filter_value="47" href="https://www.therwandan.com/category/multimedia/video/">Video</a></div></div><div id=td_uid_10_611ba78850d8d class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span"><div class="td_module_mega_menu td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.therwandan.com/despotic-dictator-sponsoring-arsenal-football-club/" rel="bookmark" title="DESPOTIC DICTATOR SPONSORING ARSENAL FOOTBALL CLUB"><img width="218" height="150" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2018/05/sddefault-1-218x150.jpg" srcset="https://www.therwandan.com/wp-content/uploads/2018/05/sddefault-1-218x150.jpg 218w, https://www.therwandan.com/wp-content/uploads/2018/05/sddefault-1-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="DESPOTIC DICTATOR SPONSORING ARSENAL FOOTBALL CLUB"/><span class="td-video-play-ico"><img width="40" height="40" class="td-retina" src="https://www.therwandan.com/wp-content/themes/Newspaperbk/images/icons/ico-video-large.png" alt="video"/></span></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/despotic-dictator-sponsoring-arsenal-football-club/" rel="bookmark" title="DESPOTIC DICTATOR SPONSORING ARSENAL FOOTBALL CLUB">DESPOTIC DICTATOR SPONSORING ARSENAL FOOTBALL CLUB</a></h3></div></div></div><div class="td-mega-span"><div class="td_module_mega_menu td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.therwandan.com/president-kagame-and-president-macron-hold-joint-press-conference-at-palais-de-lelysee/" rel="bookmark" title="President Kagame and President Macron hold joint press conference at Palais de l&#8217;Élysée"><img width="218" height="150" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2018/05/hqdefault-1-218x150.jpg" srcset="https://www.therwandan.com/wp-content/uploads/2018/05/hqdefault-1-218x150.jpg 218w, https://www.therwandan.com/wp-content/uploads/2018/05/hqdefault-1-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="President Kagame and President Macron hold joint press conference at Palais de l&#8217;Élysée"/><span class="td-video-play-ico"><img width="40" height="40" class="td-retina" src="https://www.therwandan.com/wp-content/themes/Newspaperbk/images/icons/ico-video-large.png" alt="video"/></span></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/president-kagame-and-president-macron-hold-joint-press-conference-at-palais-de-lelysee/" rel="bookmark" title="President Kagame and President Macron hold joint press conference at Palais de l&#8217;Élysée">President Kagame and President Macron hold joint press conference at Palais&#8230;</a></h3></div></div></div><div class="td-mega-span"><div class="td_module_mega_menu td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.therwandan.com/au-chairman-misstreats-kills-and-exchanges-refugees-for-money/" rel="bookmark" title="AU CHAIRMAN MISSTREATS, KILLS AND EXCHANGES REFUGEES FOR MONEY"><img width="218" height="150" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2018/03/maxresdefault-3-218x150.jpg" srcset="https://www.therwandan.com/wp-content/uploads/2018/03/maxresdefault-3-218x150.jpg 218w, https://www.therwandan.com/wp-content/uploads/2018/03/maxresdefault-3-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="AU CHAIRMAN MISSTREATS, KILLS AND EXCHANGES REFUGEES FOR MONEY"/><span class="td-video-play-ico"><img width="40" height="40" class="td-retina" src="https://www.therwandan.com/wp-content/themes/Newspaperbk/images/icons/ico-video-large.png" alt="video"/></span></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/au-chairman-misstreats-kills-and-exchanges-refugees-for-money/" rel="bookmark" title="AU CHAIRMAN MISSTREATS, KILLS AND EXCHANGES REFUGEES FOR MONEY">AU CHAIRMAN MISSTREATS, KILLS AND EXCHANGES REFUGEES FOR MONEY</a></h3></div></div></div><div class="td-mega-span"><div class="td_module_mega_menu td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.therwandan.com/new-dangerous-militia-in-rwanda/" rel="bookmark" title="NEW DANGEROUS MILITIA IN RWANDA"><img width="218" height="150" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2018/02/sddefault-218x150.jpg" srcset="https://www.therwandan.com/wp-content/uploads/2018/02/sddefault-218x150.jpg 218w, https://www.therwandan.com/wp-content/uploads/2018/02/sddefault-100x70.jpg 100w, https://www.therwandan.com/wp-content/uploads/2018/02/sddefault-20x15.jpg 20w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="NEW DANGEROUS MILITIA IN RWANDA"/><span class="td-video-play-ico"><img width="40" height="40" class="td-retina" src="https://www.therwandan.com/wp-content/themes/Newspaperbk/images/icons/ico-video-large.png" alt="video"/></span></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/new-dangerous-militia-in-rwanda/" rel="bookmark" title="NEW DANGEROUS MILITIA IN RWANDA">NEW DANGEROUS MILITIA IN RWANDA</a></h3></div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_10_611ba78850d8d" data-td_block_id="td_uid_10_611ba78850d8d"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_10_611ba78850d8d" data-td_block_id="td_uid_10_611ba78850d8d"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div></div></div></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor td-menu-item td-mega-menu menu-item-5943"><a href="https://www.therwandan.com/category/country/">Country</a><ul class="sub-menu"><li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_14_611ba7885cf90_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_14_611ba7885cf90" ><script>var block_td_uid_14_611ba7885cf90 = new tdBlock();
block_td_uid_14_611ba7885cf90.id = "td_uid_14_611ba7885cf90";
block_td_uid_14_611ba7885cf90.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"35","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_14_611ba7885cf90_rand","el_class":"","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_14_611ba7885cf90.td_column_number = "3";
block_td_uid_14_611ba7885cf90.block_type = "td_block_mega_menu";
block_td_uid_14_611ba7885cf90.post_count = "4";
block_td_uid_14_611ba7885cf90.found_posts = "906";
block_td_uid_14_611ba7885cf90.header_color = "";
block_td_uid_14_611ba7885cf90.ajax_pagination_infinite_stop = "";
block_td_uid_14_611ba7885cf90.max_num_pages = "227";
tdBlocksArray.push(block_td_uid_14_611ba7885cf90);</script> <script>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</script> <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_14_611ba7885cf90" id="td_uid_15_611ba7886af4a" data-td_block_id="td_uid_14_611ba7885cf90" data-td_filter_value="" href="https://www.therwandan.com/category/country/">All</a><a class="mega-menu-sub-cat-td_uid_14_611ba7885cf90"  id="td_uid_16_611ba7886b08f" data-td_block_id="td_uid_14_611ba7885cf90" data-td_filter_value="16" href="https://www.therwandan.com/category/country/economy/">Economy</a><a class="mega-menu-sub-cat-td_uid_14_611ba7885cf90"  id="td_uid_17_611ba7886b218" data-td_block_id="td_uid_14_611ba7885cf90" data-td_filter_value="1" href="https://www.therwandan.com/category/country/history/">History</a><a class="mega-menu-sub-cat-td_uid_14_611ba7885cf90"  id="td_uid_18_611ba7886b351" data-td_block_id="td_uid_14_611ba7885cf90" data-td_filter_value="19" href="https://www.therwandan.com/category/country/justice/">Justice</a><a class="mega-menu-sub-cat-td_uid_14_611ba7885cf90"  id="td_uid_19_611ba7886b4bf" data-td_block_id="td_uid_14_611ba7885cf90" data-td_filter_value="40" href="https://www.therwandan.com/category/country/lifestyle-country/">Life &amp; Society</a><a class="mega-menu-sub-cat-td_uid_14_611ba7885cf90"  id="td_uid_20_611ba7886b641" data-td_block_id="td_uid_14_611ba7885cf90" data-td_filter_value="36" href="https://www.therwandan.com/category/country/security/">Security</a></div></div><div id=td_uid_14_611ba7885cf90 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span"><div class="td_module_mega_menu td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.therwandan.com/kagame-is-giving-more-cash-to-the-english-football-club-arsenal-to-wear-a-rwanda-logo-on-their-shirt-sleeves/" rel="bookmark" title="Kagame is giving more cash to the English Football Club, Arsenal, to wear a Rwanda logo on their shirt sleeves."><img width="218" height="150" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2021/08/kagame-arsenal-218x150.jpg" srcset="https://www.therwandan.com/wp-content/uploads/2021/08/kagame-arsenal-218x150.jpg 218w, https://www.therwandan.com/wp-content/uploads/2021/08/kagame-arsenal-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Kagame is giving more cash to the English Football Club, Arsenal, to wear a Rwanda logo on their shirt sleeves."/></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/kagame-is-giving-more-cash-to-the-english-football-club-arsenal-to-wear-a-rwanda-logo-on-their-shirt-sleeves/" rel="bookmark" title="Kagame is giving more cash to the English Football Club, Arsenal, to wear a Rwanda logo on their shirt sleeves.">Kagame is giving more cash to the English Football Club, Arsenal,&#8230;</a></h3></div></div></div><div class="td-mega-span"><div class="td_module_mega_menu td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.therwandan.com/advantages-of-gambling-at-bet365-on-mobile-devices/" rel="bookmark" title="Advantages of gambling at Bet365 on mobile devices"><img width="218" height="150" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2021/08/Skjermbilde-2021-08-17-kl.-13.14.09-218x150.png" srcset="https://www.therwandan.com/wp-content/uploads/2021/08/Skjermbilde-2021-08-17-kl.-13.14.09-218x150.png 218w, https://www.therwandan.com/wp-content/uploads/2021/08/Skjermbilde-2021-08-17-kl.-13.14.09-100x70.png 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Advantages of gambling at Bet365 on mobile devices"/></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/advantages-of-gambling-at-bet365-on-mobile-devices/" rel="bookmark" title="Advantages of gambling at Bet365 on mobile devices">Advantages of gambling at Bet365 on mobile devices</a></h3></div></div></div><div class="td-mega-span"><div class="td_module_mega_menu td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.therwandan.com/interpol-ambassador-gasana-eugene-richard-defeated-president-kagame-paul/" rel="bookmark" title="INTERPOL: Ambassador Gasana Eugène Richard defeated President Kagame Paul"><img width="218" height="150" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2021/08/Skjermbilde-2021-08-16-kl.-20.21.06-218x150.png" srcset="https://www.therwandan.com/wp-content/uploads/2021/08/Skjermbilde-2021-08-16-kl.-20.21.06-218x150.png 218w, https://www.therwandan.com/wp-content/uploads/2021/08/Skjermbilde-2021-08-16-kl.-20.21.06-100x70.png 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="INTERPOL: Ambassador Gasana Eugène Richard defeated President Kagame Paul"/></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/interpol-ambassador-gasana-eugene-richard-defeated-president-kagame-paul/" rel="bookmark" title="INTERPOL: Ambassador Gasana Eugène Richard defeated President Kagame Paul">INTERPOL: Ambassador Gasana Eugène Richard defeated President Kagame Paul</a></h3></div></div></div><div class="td-mega-span"><div class="td_module_mega_menu td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.therwandan.com/kagames-supporters-for-his-vaccine-manufacturing-plant-have-increased-to-four-and-us3-5-million/" rel="bookmark" title="Kagame’s Supporters for his Vaccine Manufacturing Plant Have Increased to Four and US$3.5 Million"><img width="218" height="150" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2020/12/Skjermbilde-2020-12-23-kl.-06.17.48-218x150.png" srcset="https://www.therwandan.com/wp-content/uploads/2020/12/Skjermbilde-2020-12-23-kl.-06.17.48-218x150.png 218w, https://www.therwandan.com/wp-content/uploads/2020/12/Skjermbilde-2020-12-23-kl.-06.17.48-100x70.png 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Kagame’s Supporters for his Vaccine Manufacturing Plant Have Increased to Four and US$3.5 Million"/></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/kagames-supporters-for-his-vaccine-manufacturing-plant-have-increased-to-four-and-us3-5-million/" rel="bookmark" title="Kagame’s Supporters for his Vaccine Manufacturing Plant Have Increased to Four and US$3.5 Million">Kagame’s Supporters for his Vaccine Manufacturing Plant Have Increased to Four&#8230;</a></h3></div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_14_611ba7885cf90" data-td_block_id="td_uid_14_611ba7885cf90"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_14_611ba7885cf90" data-td_block_id="td_uid_14_611ba7885cf90"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div></div></div></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-3805"><a href="https://www.therwandan.com/category/analysis/">Analysis</a><ul class="sub-menu"><li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_21_611ba7888e471_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_21_611ba7888e471" ><script>var block_td_uid_21_611ba7888e471 = new tdBlock();
block_td_uid_21_611ba7888e471.id = "td_uid_21_611ba7888e471";
block_td_uid_21_611ba7888e471.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"31","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_21_611ba7888e471_rand","el_class":"","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_21_611ba7888e471.td_column_number = "3";
block_td_uid_21_611ba7888e471.block_type = "td_block_mega_menu";
block_td_uid_21_611ba7888e471.post_count = "5";
block_td_uid_21_611ba7888e471.found_posts = "436";
block_td_uid_21_611ba7888e471.header_color = "";
block_td_uid_21_611ba7888e471.ajax_pagination_infinite_stop = "";
block_td_uid_21_611ba7888e471.max_num_pages = "88";
tdBlocksArray.push(block_td_uid_21_611ba7888e471);</script><div id=td_uid_21_611ba7888e471 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span"><div class="td_module_mega_menu td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.therwandan.com/the-new-association-of-genocide-survivors-and-the-fear-of-the-kigali-regime/" rel="bookmark" title="Igicumbi: the new association of genocide survivors and the fear of the Kigali regime "><img width="218" height="150" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2021/08/Skjermbilde-2021-08-01-kl.-19.53.29-218x150.png" srcset="https://www.therwandan.com/wp-content/uploads/2021/08/Skjermbilde-2021-08-01-kl.-19.53.29-218x150.png 218w, https://www.therwandan.com/wp-content/uploads/2021/08/Skjermbilde-2021-08-01-kl.-19.53.29-100x70.png 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Igicumbi: the new association of genocide survivors and the fear of the Kigali regime "/></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/the-new-association-of-genocide-survivors-and-the-fear-of-the-kigali-regime/" rel="bookmark" title="Igicumbi: the new association of genocide survivors and the fear of the Kigali regime ">Igicumbi: the new association of genocide survivors and the fear of&#8230;</a></h3></div></div></div><div class="td-mega-span"><div class="td_module_mega_menu td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.therwandan.com/must-rwanda-continue-to-receive-belgian-aid/" rel="bookmark" title="Must Rwanda continue to receive Belgian aid?"><img width="200" height="150" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2015/12/filip-200x150.jpg" srcset="https://www.therwandan.com/wp-content/uploads/2015/12/filip-200x150.jpg 200w, https://www.therwandan.com/wp-content/uploads/2015/12/filip-80x60.jpg 80w" sizes="(max-width: 200px) 100vw, 200px" alt="" title="Must Rwanda continue to receive Belgian aid?"/></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/must-rwanda-continue-to-receive-belgian-aid/" rel="bookmark" title="Must Rwanda continue to receive Belgian aid?">Must Rwanda continue to receive Belgian aid?</a></h3></div></div></div><div class="td-mega-span"><div class="td_module_mega_menu td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.therwandan.com/how-basic-rights-of-felicien-kabuga-are-violated/" rel="bookmark" title="How basic rights of Félicien Kabuga are violated?"><img width="218" height="150" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2021/01/Kabuga-Felicien-218x150.png" srcset="https://www.therwandan.com/wp-content/uploads/2021/01/Kabuga-Felicien-218x150.png 218w, https://www.therwandan.com/wp-content/uploads/2021/01/Kabuga-Felicien-100x70.png 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="How basic rights of Félicien Kabuga are violated?"/></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/how-basic-rights-of-felicien-kabuga-are-violated/" rel="bookmark" title="How basic rights of Félicien Kabuga are violated?">How basic rights of Félicien Kabuga are violated?</a></h3></div></div></div><div class="td-mega-span"><div class="td_module_mega_menu td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.therwandan.com/funds-of-his-social-security-seized-by-regime-officials-for-their-business-what-is-fate-of-the-rwandan-worker/" rel="bookmark" title="Funds of his social security seized by regime officials for their business, what is fate of the Rwandan worker?"><img width="218" height="150" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2021/07/Skjermbilde-2021-07-14-kl.-23.18.54-218x150.png" srcset="https://www.therwandan.com/wp-content/uploads/2021/07/Skjermbilde-2021-07-14-kl.-23.18.54-218x150.png 218w, https://www.therwandan.com/wp-content/uploads/2021/07/Skjermbilde-2021-07-14-kl.-23.18.54-100x70.png 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Funds of his social security seized by regime officials for their business, what is fate of the Rwandan worker?"/></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/funds-of-his-social-security-seized-by-regime-officials-for-their-business-what-is-fate-of-the-rwandan-worker/" rel="bookmark" title="Funds of his social security seized by regime officials for their business, what is fate of the Rwandan worker?">Funds of his social security seized by regime officials for their&#8230;</a></h3></div></div></div><div class="td-mega-span"><div class="td_module_mega_menu td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.therwandan.com/what-is-behind-the-rushed-adoption-of-new-law-on-rwandan-citizenship/" rel="bookmark" title="What is behind the rushed adoption of new law on Rwandan citizenship?"><img width="218" height="150" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2021/07/Professor-Philip-Cotton-218x150.jpg" srcset="https://www.therwandan.com/wp-content/uploads/2021/07/Professor-Philip-Cotton-218x150.jpg 218w, https://www.therwandan.com/wp-content/uploads/2021/07/Professor-Philip-Cotton-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="What is behind the rushed adoption of new law on Rwandan citizenship?"/></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/what-is-behind-the-rushed-adoption-of-new-law-on-rwandan-citizenship/" rel="bookmark" title="What is behind the rushed adoption of new law on Rwandan citizenship?">What is behind the rushed adoption of new law on Rwandan&#8230;</a></h3></div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_21_611ba7888e471" data-td_block_id="td_uid_21_611ba7888e471"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_21_611ba7888e471" data-td_block_id="td_uid_21_611ba7888e471"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div></div></div></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-5934"><a href="https://www.therwandan.com/category/opinion/">Opinion</a><ul class="sub-menu"><li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_22_611ba788988d1_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_22_611ba788988d1" ><script>var block_td_uid_22_611ba788988d1 = new tdBlock();
block_td_uid_22_611ba788988d1.id = "td_uid_22_611ba788988d1";
block_td_uid_22_611ba788988d1.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"27","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_22_611ba788988d1_rand","el_class":"","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_22_611ba788988d1.td_column_number = "3";
block_td_uid_22_611ba788988d1.block_type = "td_block_mega_menu";
block_td_uid_22_611ba788988d1.post_count = "5";
block_td_uid_22_611ba788988d1.found_posts = "656";
block_td_uid_22_611ba788988d1.header_color = "";
block_td_uid_22_611ba788988d1.ajax_pagination_infinite_stop = "";
block_td_uid_22_611ba788988d1.max_num_pages = "132";
tdBlocksArray.push(block_td_uid_22_611ba788988d1);</script><div id=td_uid_22_611ba788988d1 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span"><div class="td_module_mega_menu td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.therwandan.com/repression-in-rwanda-critics-are-jailed-or-killed-aimable-karasira-is-in-danger/" rel="bookmark" title="Repression in Rwanda: critics are jailed or killed &#8211; Aimable Karasira is in danger!"><img width="218" height="150" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2021/08/WhatsApp-Image-2021-08-09-at-16.42.15-218x150.jpeg" srcset="https://www.therwandan.com/wp-content/uploads/2021/08/WhatsApp-Image-2021-08-09-at-16.42.15-218x150.jpeg 218w, https://www.therwandan.com/wp-content/uploads/2021/08/WhatsApp-Image-2021-08-09-at-16.42.15-100x70.jpeg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Repression in Rwanda: critics are jailed or killed &#8211; Aimable Karasira is in danger!"/></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/repression-in-rwanda-critics-are-jailed-or-killed-aimable-karasira-is-in-danger/" rel="bookmark" title="Repression in Rwanda: critics are jailed or killed &#8211; Aimable Karasira is in danger!">Repression in Rwanda: critics are jailed or killed &#8211; Aimable Karasira&#8230;</a></h3></div></div></div><div class="td-mega-span"><div class="td_module_mega_menu td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.therwandan.com/kabuga-has-been-denied-his-basics-human-rights-family-says/" rel="bookmark" title="Kabuga has been denied his basics human rights: Family says"><img width="218" height="150" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2021/01/Kabuga-Felicien-218x150.png" srcset="https://www.therwandan.com/wp-content/uploads/2021/01/Kabuga-Felicien-218x150.png 218w, https://www.therwandan.com/wp-content/uploads/2021/01/Kabuga-Felicien-100x70.png 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Kabuga has been denied his basics human rights: Family says"/></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/kabuga-has-been-denied-his-basics-human-rights-family-says/" rel="bookmark" title="Kabuga has been denied his basics human rights: Family says">Kabuga has been denied his basics human rights: Family says</a></h3></div></div></div><div class="td-mega-span"><div class="td_module_mega_menu td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.therwandan.com/president-kagame-met-chairman-kagame/" rel="bookmark" title="President Kagame met Chairman Kagame"><img width="218" height="150" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2021/07/president-vs-chairman-218x150.jpg" srcset="https://www.therwandan.com/wp-content/uploads/2021/07/president-vs-chairman-218x150.jpg 218w, https://www.therwandan.com/wp-content/uploads/2021/07/president-vs-chairman-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="President Kagame met Chairman Kagame"/></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/president-kagame-met-chairman-kagame/" rel="bookmark" title="President Kagame met Chairman Kagame">President Kagame met Chairman Kagame</a></h3></div></div></div><div class="td-mega-span"><div class="td_module_mega_menu td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.therwandan.com/july-25-a-call-to-action-to-put-an-end-to-the-persecution-of-young-rwandans/" rel="bookmark" title="July 25 &#8211; A call to action to put an end to the persecution of young Rwandans"><img width="218" height="150" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2020/02/Kizito-Mihigo1-218x150.jpg" srcset="https://www.therwandan.com/wp-content/uploads/2020/02/Kizito-Mihigo1-218x150.jpg 218w, https://www.therwandan.com/wp-content/uploads/2020/02/Kizito-Mihigo1-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="July 25 &#8211; A call to action to put an end to the persecution of young Rwandans"/></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/july-25-a-call-to-action-to-put-an-end-to-the-persecution-of-young-rwandans/" rel="bookmark" title="July 25 &#8211; A call to action to put an end to the persecution of young Rwandans">July 25 &#8211; A call to action to put an end&#8230;</a></h3></div></div></div><div class="td-mega-span"><div class="td_module_mega_menu td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.therwandan.com/supporters-legal-observers-rally-around-hotel-rwanda-hero/" rel="bookmark" title="Supporters, Legal Observers Rally Around Hotel Rwanda Hero"><img width="218" height="150" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2017/03/rusesa-218x150.jpeg" srcset="https://www.therwandan.com/wp-content/uploads/2017/03/rusesa-218x150.jpeg 218w, https://www.therwandan.com/wp-content/uploads/2017/03/rusesa-100x70.jpeg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Supporters, Legal Observers Rally Around Hotel Rwanda Hero"/></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/supporters-legal-observers-rally-around-hotel-rwanda-hero/" rel="bookmark" title="Supporters, Legal Observers Rally Around Hotel Rwanda Hero">Supporters, Legal Observers Rally Around Hotel Rwanda Hero</a></h3></div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_22_611ba788988d1" data-td_block_id="td_uid_22_611ba788988d1"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_22_611ba788988d1" data-td_block_id="td_uid_22_611ba788988d1"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div></div></div></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-3038"><a href="https://www.therwandan.com/category/politics/">Politics</a><ul class="sub-menu"><li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_23_611ba788a6bb9_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_23_611ba788a6bb9" ><script>var block_td_uid_23_611ba788a6bb9 = new tdBlock();
block_td_uid_23_611ba788a6bb9.id = "td_uid_23_611ba788a6bb9";
block_td_uid_23_611ba788a6bb9.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"5","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_23_611ba788a6bb9_rand","el_class":"","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_23_611ba788a6bb9.td_column_number = "3";
block_td_uid_23_611ba788a6bb9.block_type = "td_block_mega_menu";
block_td_uid_23_611ba788a6bb9.post_count = "4";
block_td_uid_23_611ba788a6bb9.found_posts = "575";
block_td_uid_23_611ba788a6bb9.header_color = "";
block_td_uid_23_611ba788a6bb9.ajax_pagination_infinite_stop = "";
block_td_uid_23_611ba788a6bb9.max_num_pages = "144";
tdBlocksArray.push(block_td_uid_23_611ba788a6bb9);</script> <script>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</script> <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_23_611ba788a6bb9" id="td_uid_24_611ba788b08ee" data-td_block_id="td_uid_23_611ba788a6bb9" data-td_filter_value="" href="https://www.therwandan.com/category/politics/">All</a><a class="mega-menu-sub-cat-td_uid_23_611ba788a6bb9"  id="td_uid_25_611ba788b0a35" data-td_block_id="td_uid_23_611ba788a6bb9" data-td_filter_value="38" href="https://www.therwandan.com/category/politics/events/">Events</a><a class="mega-menu-sub-cat-td_uid_23_611ba788a6bb9"  id="td_uid_26_611ba788b0b86" data-td_block_id="td_uid_23_611ba788a6bb9" data-td_filter_value="39" href="https://www.therwandan.com/category/politics/politicians/">politicians</a><a class="mega-menu-sub-cat-td_uid_23_611ba788a6bb9"  id="td_uid_27_611ba788b0cdd" data-td_block_id="td_uid_23_611ba788a6bb9" data-td_filter_value="29" href="https://www.therwandan.com/category/politics/press-release/">Press Release</a></div></div><div id=td_uid_23_611ba788a6bb9 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span"><div class="td_module_mega_menu td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.therwandan.com/appeal-to-dutch-parliament-to-end-the-handing-over-of-political-refugees-to-the-rwandan-brutal-regime/" rel="bookmark" title="APPEAL TO DUTCH PARLIAMENT TO END THE HANDING OVER OF POLITICAL REFUGEES TO THE RWANDAN BRUTAL REGIME."><img width="218" height="150" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2021/02/RBB-218x150.jpg" srcset="https://www.therwandan.com/wp-content/uploads/2021/02/RBB-218x150.jpg 218w, https://www.therwandan.com/wp-content/uploads/2021/02/RBB-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="APPEAL TO DUTCH PARLIAMENT TO END THE HANDING OVER OF POLITICAL REFUGEES TO THE RWANDAN BRUTAL REGIME."/></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/appeal-to-dutch-parliament-to-end-the-handing-over-of-political-refugees-to-the-rwandan-brutal-regime/" rel="bookmark" title="APPEAL TO DUTCH PARLIAMENT TO END THE HANDING OVER OF POLITICAL REFUGEES TO THE RWANDAN BRUTAL REGIME.">APPEAL TO DUTCH PARLIAMENT TO END THE HANDING OVER OF POLITICAL&#8230;</a></h3></div></div></div><div class="td-mega-span"><div class="td_module_mega_menu td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.therwandan.com/rwanda-hills-of-healing-dr-theogene-rudasingwa/" rel="bookmark" title="RWANDA-Hills of Healing: Dr Theogene Rudasingwa"><img width="218" height="150" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2021/08/Skjermbilde-2021-08-01-kl.-15.22.23-218x150.png" srcset="https://www.therwandan.com/wp-content/uploads/2021/08/Skjermbilde-2021-08-01-kl.-15.22.23-218x150.png 218w, https://www.therwandan.com/wp-content/uploads/2021/08/Skjermbilde-2021-08-01-kl.-15.22.23-100x70.png 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="RWANDA-Hills of Healing: Dr Theogene Rudasingwa"/></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/rwanda-hills-of-healing-dr-theogene-rudasingwa/" rel="bookmark" title="RWANDA-Hills of Healing: Dr Theogene Rudasingwa">RWANDA-Hills of Healing: Dr Theogene Rudasingwa</a></h3></div></div></div><div class="td-mega-span"><div class="td_module_mega_menu td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.therwandan.com/rmdc-mrcd-ubumwe-reaction-of-the-ongoing-paul-rusesabagina-trial/" rel="bookmark" title="RMDC (MRCD-UBUMWE) reaction of the ongoing Paul Rusesabagina trial"><img width="218" height="150" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2018/07/MRCD-218x150.jpg" srcset="https://www.therwandan.com/wp-content/uploads/2018/07/MRCD-218x150.jpg 218w, https://www.therwandan.com/wp-content/uploads/2018/07/MRCD-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="RMDC (MRCD-UBUMWE) reaction of the ongoing Paul Rusesabagina trial"/></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/rmdc-mrcd-ubumwe-reaction-of-the-ongoing-paul-rusesabagina-trial/" rel="bookmark" title="RMDC (MRCD-UBUMWE) reaction of the ongoing Paul Rusesabagina trial">RMDC (MRCD-UBUMWE) reaction of the ongoing Paul Rusesabagina trial</a></h3></div></div></div><div class="td-mega-span"><div class="td_module_mega_menu td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.therwandan.com/rnc-is-very-concerned-by-the-deployment-of-rwandan-defence-forces-and-police-in-the-cabo-delgado-province-of-mozambique/" rel="bookmark" title="RNC is very concerned by the deployment of Rwandan Forces and Police in Mozambique"><img width="218" height="150" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2014/06/RNC-218x150.jpg" srcset="https://www.therwandan.com/wp-content/uploads/2014/06/RNC-218x150.jpg 218w, https://www.therwandan.com/wp-content/uploads/2014/06/RNC-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="RNC is very concerned by the deployment of Rwandan Forces and Police in Mozambique"/></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/rnc-is-very-concerned-by-the-deployment-of-rwandan-defence-forces-and-police-in-the-cabo-delgado-province-of-mozambique/" rel="bookmark" title="RNC is very concerned by the deployment of Rwandan Forces and Police in Mozambique">RNC is very concerned by the deployment of Rwandan Forces and&#8230;</a></h3></div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_23_611ba788a6bb9" data-td_block_id="td_uid_23_611ba788a6bb9"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_23_611ba788a6bb9" data-td_block_id="td_uid_23_611ba788a6bb9"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div></div></div></li></ul></li></ul></div></div><div class="td-search-wrapper"><div id="td-top-search"><div class="header-search-wrap"><div class="dropdown header-search"> <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a> <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a></div></div></div></div><div class="header-search-wrap"><div class="dropdown header-search"><div class="td-drop-down-search" aria-labelledby="td-header-search-button"><form method="get" class="td-search-form" action="https://www.therwandan.com/"><div role="search" class="td-head-form-search-wrap"> <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" /></div></form><div id="td-aj-search"></div></div></div></div></div></div></div><div class="td-banner-wrap-full td-logo-wrap-full td-logo-mobile-loaded"><div class="td-header-sp-logo"> <a class="td-main-logo" href="https://www.therwandan.com/"> <img class="td-retina-data"  data-retina="https://www.therwandan.com/wp-content/uploads/2021/05/logo-The-rwandan.png" src="https://www.therwandan.com/wp-content/uploads/2021/05/logo-The-rwandan.png" alt=""/> <span class="td-visual-hidden">Therwandan</span> </a></div></div><div class="td-banner-wrap-full td-banner-bg"><div class="td-container-header td-header-row td-header-header"><div class="td-header-sp-recs"><div class="td-header-rec-wrap">  <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-header "> <script type="text/javascript">var td_screen_width = window.innerWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:970px;height:250px" data-ad-client="ca-pub-2768989567748188" data-ad-slot="5217293365"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-2768989567748188" data-ad-slot="5217293365"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-2768989567748188" data-ad-slot="5217293365"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:320px;height:50px" data-ad-client="ca-pub-2768989567748188" data-ad-slot="5217293365"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }</script> </div></div></div></div></div></div><div class="td-main-content-wrap"><div class="td-container td-post-template-5 "><div class="td-crumb-container"><div class="entry-crumbs"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="" class="entry-crumb" itemprop="url" href="https://www.therwandan.com/"><span itemprop="title">Home</span></a></span> <i class="td-icon-right td-bread-sep"></i> <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="View all posts in Country" class="entry-crumb" itemprop="url" href="https://www.therwandan.com/category/country/"><span itemprop="title">Country</span></a></span> <i class="td-icon-right td-bread-sep"></i> <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="View all posts in Economy" class="entry-crumb" itemprop="url" href="https://www.therwandan.com/category/country/economy/"><span itemprop="title">Economy</span></a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last" itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><meta itemprop="title" content = "Kagame is giving more cash to the English Football Club, Arsenal, to..."><meta itemprop="url" content = "https://www.therwandan.com/kagame-is-giving-more-cash-to-the-english-football-club-arsenal-to-wear-a-rwanda-logo-on-their-shirt-sleeves/">Kagame is giving more cash to the English Football Club, Arsenal, to...</span></div></div><div class="td-pb-row"><div class="td-pb-span8 td-main-content" role="main"><div class="td-ss-main-content"><article id="post-16895" class="post-16895 post type-post status-publish format-standard has-post-thumbnail hentry category-economy" itemscope itemtype="https://schema.org/Article"><div class="td-post-header"><ul class="td-category"><li class="entry-category"><a  href="https://www.therwandan.com/category/country/">Country</a></li><li class="entry-category"><a  href="https://www.therwandan.com/category/country/economy/">Economy</a></li></ul><header class="td-post-title"><h1 class="entry-title">Kagame is giving more cash to the English Football Club, Arsenal, to wear a Rwanda logo on their shirt sleeves.</h1><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-08-17T12:11:13+00:00" >August 17, 2021</time></span></div></header></div><div class="td-post-sharing td-post-sharing-top "><div class="td-default-sharing"> <a class="td-social-sharing-buttons td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.therwandan.com%2Fkagame-is-giving-more-cash-to-the-english-football-club-arsenal-to-wear-a-rwanda-logo-on-their-shirt-sleeves%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-facebook"></i><div class="td-social-but-text">Share on Facebook</div></a> <a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=Kagame+is+giving+more+cash+to+the+English+Football+Club%2C+Arsenal%2C+to+wear+a+Rwanda+logo+on+their+shirt+sleeves.&url=https%3A%2F%2Fwww.therwandan.com%2Fkagame-is-giving-more-cash-to-the-english-football-club-arsenal-to-wear-a-rwanda-logo-on-their-shirt-sleeves%2F&via=Therwandan"  ><i class="td-icon-twitter"></i><div class="td-social-but-text">Tweet on Twitter</div></a> <a class="td-social-sharing-buttons td-social-google" href="https://plus.google.com/share?url=https://www.therwandan.com/kagame-is-giving-more-cash-to-the-english-football-club-arsenal-to-wear-a-rwanda-logo-on-their-shirt-sleeves/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-googleplus"></i></a> <a class="td-social-sharing-buttons td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://www.therwandan.com/kagame-is-giving-more-cash-to-the-english-football-club-arsenal-to-wear-a-rwanda-logo-on-their-shirt-sleeves/&amp;media=https://www.therwandan.com/wp-content/uploads/2021/08/kagame-arsenal.jpg&description=Kagame+is+giving+more+cash+to+the+English+Football+Club%2C+Arsenal%2C+to+wear+a+Rwanda+logo+on+their+shirt+sleeves." onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-pinterest"></i></a> <a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=Kagame+is+giving+more+cash+to+the+English+Football+Club%2C+Arsenal%2C+to+wear+a+Rwanda+logo+on+their+shirt+sleeves.%20-%20https%3A%2F%2Fwww.therwandan.com%2Fkagame-is-giving-more-cash-to-the-english-football-club-arsenal-to-wear-a-rwanda-logo-on-their-shirt-sleeves%2F" ><i class="td-icon-whatsapp"></i></a></div></div><div class="td-post-content"><div class="td-a-rec td-a-rec-id-content_top  "><div id="1588x728x90x309x_ADSLOT1" clickTrack="%%CLICK_URL_ESC%%"></div> <script type="text/javascript" async src="//served-by.pixfuture.com/www/delivery/headerbid.js" slotId="1588x728x90x309x_ADSLOT1"></script></div><p id="c5c6" class="fm dl fn bb da fo fp fq fr fs ft fu fv fw fx fy fz ga gb gc gd ge gf gg gh gi gj"><em>The Rwandan Strongman is flush with money from his latest acquisition of US$620 million debt.</em></p><p id="ae0c" class="hd he fn hf b hg hh hi hj hk hl hm hn ho hp hq hr hs ht hu hv hw dn gj" data-selectable-paragraph="">By <strong>David Himbara</strong></p><p class="hd he fn hf b hg hh hi hj hk hl hm hn ho hp hq hr hs ht hu hv hw dn gj" data-selectable-paragraph="">General Paul Kagame loves the English Football Club, Arsenal. He describes himself as Arsenal diehard fan who is sick and tired of their poor performance. He has been paying them US$41 million a year to wear on shirt sleeves “Visit Rwanda” since 2018. The Rwandan strongman has renewed his Arsenal sponsorship for four more years.</p><figure class="hy hz ia ib ic id eu ev paragraph-image"><div class="ie if ap ig w ih" tabindex="0" role="button"><div class="eu ev hx"><img loading="lazy" class="w ii ij" role="presentation" src="https://miro.medium.com/max/1400/1*gk7yU3KN9juKFVKJFeceAg@2x.jpeg" alt="" width="700" height="571" /></div></div></figure><p id="46cb" class="hd he fn hf b hg ik hh hi hj il hk hl hm im hn ho hp in hq hr hs io ht hu hw dn gj" data-selectable-paragraph="">General Paul Kagame recently denounced Arsena<span id="rmm">l</span> after the English Football Club lost 2–0 to Brentford. The Rwandan strongman who is a diehard supporter of Arsenal lectured the football club that “We must not excuse or accept mediocrity. A team has to be built with purpose to win win win.” Kagame made it clear that he is tired of Arsenal’s poor performance: “It’s been a struggle of about decade(s) -ups and downs – more downs until this point.”</p>  <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-content_inline "> <script type="text/javascript">var td_screen_width = window.innerWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:640px;height:190px" data-ad-client="ca-pub-2768989567748188" data-ad-slot="6563198412"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-2768989567748188" data-ad-slot="6563198412"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-2768989567748188" data-ad-slot="6563198412"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:320px;height:50px" data-ad-client="ca-pub-2768989567748188" data-ad-slot="6563198412"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }</script> </div><p id="6f90" class="hd he fn hf b hg ik hh hi hj il hk hl hm im hn ho hp in hq hr hs io ht hu hw dn gj" data-selectable-paragraph="">Days after his lecture to Arsenal, Kagame is once again giving serious cash to the football club to wear “Visit Rwanda” on their shirt sleeves. Back in 2018, Kagame gave Arsenal a three-year sponsorship deal of £30 million or US$41 million a year to wear “Visit Rwanda.” Now, Kagame has given Arsenal a new four-year deal £10million or US$13.8 million a year from 2021 to 2025, according to <a class="dt ip" href="https://www.football.london/arsenal-fc/news/arsenal-make-sponsorship-decision-following-21323533" rel="noopener nofollow">Football.London</a>. Kagame is now flush with cash, having recently raised US$620 million for paying off older loans and financing “priority projects.” To him, Arsenal is, of course, a priority project. Stay tuned.</p><div class="td-a-rec td-a-rec-id-content_bottom  "><div id="taboola-below-article-thumbnails"></div> <script type="text/javascript">window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'thumbnails-a',
    container: 'taboola-below-article-thumbnails',
    placement: 'Below Article Thumbnails',
    target_type: 'mix'
  });</script></div></div><footer><div class="td-post-source-tags"></div><div class="td-post-sharing td-post-sharing-bottom td-with-like"><span class="td-post-share-title">SHARE</span><div class="td-default-sharing"> <a class="td-social-sharing-buttons td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.therwandan.com%2Fkagame-is-giving-more-cash-to-the-english-football-club-arsenal-to-wear-a-rwanda-logo-on-their-shirt-sleeves%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-facebook"></i><div class="td-social-but-text">Facebook</div></a> <a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=Kagame+is+giving+more+cash+to+the+English+Football+Club%2C+Arsenal%2C+to+wear+a+Rwanda+logo+on+their+shirt+sleeves.&url=https%3A%2F%2Fwww.therwandan.com%2Fkagame-is-giving-more-cash-to-the-english-football-club-arsenal-to-wear-a-rwanda-logo-on-their-shirt-sleeves%2F&via=Therwandan"><i class="td-icon-twitter"></i><div class="td-social-but-text">Twitter</div></a> <a class="td-social-sharing-buttons td-social-google" href="https://plus.google.com/share?url=https://www.therwandan.com/kagame-is-giving-more-cash-to-the-english-football-club-arsenal-to-wear-a-rwanda-logo-on-their-shirt-sleeves/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-googleplus"></i></a> <a class="td-social-sharing-buttons td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://www.therwandan.com/kagame-is-giving-more-cash-to-the-english-football-club-arsenal-to-wear-a-rwanda-logo-on-their-shirt-sleeves/&amp;media=https://www.therwandan.com/wp-content/uploads/2021/08/kagame-arsenal.jpg&description=Kagame+is+giving+more+cash+to+the+English+Football+Club%2C+Arsenal%2C+to+wear+a+Rwanda+logo+on+their+shirt+sleeves." onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-pinterest"></i></a> <a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=Kagame+is+giving+more+cash+to+the+English+Football+Club%2C+Arsenal%2C+to+wear+a+Rwanda+logo+on+their+shirt+sleeves.%20-%20https%3A%2F%2Fwww.therwandan.com%2Fkagame-is-giving-more-cash-to-the-english-football-club-arsenal-to-wear-a-rwanda-logo-on-their-shirt-sleeves%2F" ><i class="td-icon-whatsapp"></i></a></div><div class="td-classic-sharing"><ul><li class="td-classic-facebook"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://www.therwandan.com/kagame-is-giving-more-cash-to-the-english-football-club-arsenal-to-wear-a-rwanda-logo-on-their-shirt-sleeves/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></li><li class="td-classic-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://www.therwandan.com/kagame-is-giving-more-cash-to-the-english-football-club-arsenal-to-wear-a-rwanda-logo-on-their-shirt-sleeves/" data-text="Kagame is giving more cash to the English Football Club, Arsenal, to wear a Rwanda logo on their shirt sleeves." data-via="" data-lang="en">tweet</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></li></ul></div></div><div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://www.therwandan.com/advantages-of-gambling-at-bet365-on-mobile-devices/">Advantages of gambling at Bet365 on mobile devices</a></div></div><div class="td-next-prev-separator"></div></div><div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://www.therwandan.com/author/therwda/">therwda</a></span></div> <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="therwda"></span><meta itemprop="datePublished" content="2021-08-17T12:11:13+00:00"><meta itemprop="dateModified" content="2021-08-17T12:11:13+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.therwandan.com/kagame-is-giving-more-cash-to-the-english-football-club-arsenal-to-wear-a-rwanda-logo-on-their-shirt-sleeves/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.therwandan.com/wp-content/uploads/2021/05/logo-The-rwandan.png"></span><meta itemprop="name" content="Therwandan"></span><meta itemprop="headline " content="Kagame is giving more cash to the English Football Club, Arsenal, to wear a Rwanda logo on their shirt sleeves."><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.therwandan.com/wp-content/uploads/2021/08/kagame-arsenal.jpg"><meta itemprop="width" content="1121"><meta itemprop="height" content="1806"></span></footer></article><div class="td_block_wrap td_block_related_posts td_uid_32_611ba788cae78_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_32_611ba788cae78" ><script>var block_td_uid_32_611ba788cae78 = new tdBlock();
block_td_uid_32_611ba788cae78.id = "td_uid_32_611ba788cae78";
block_td_uid_32_611ba788cae78.atts = '{"limit":3,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_custom_related","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_32_611ba788cae78_rand","el_class":"","offset":"","css":"","live_filter":"cur_post_same_categories","live_filter_cur_post_id":16895,"live_filter_cur_post_author":"2"}';
block_td_uid_32_611ba788cae78.td_column_number = "3";
block_td_uid_32_611ba788cae78.block_type = "td_block_related_posts";
block_td_uid_32_611ba788cae78.post_count = "3";
block_td_uid_32_611ba788cae78.found_posts = "426";
block_td_uid_32_611ba788cae78.header_color = "";
block_td_uid_32_611ba788cae78.ajax_pagination_infinite_stop = "";
block_td_uid_32_611ba788cae78.max_num_pages = "142";
tdBlocksArray.push(block_td_uid_32_611ba788cae78);</script><h4 class="td-related-title"><a id="td_uid_33_611ba788d2404" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_32_611ba788cae78" href="#">RELATED ARTICLES</a><a id="td_uid_34_611ba788d2451" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_32_611ba788cae78" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_32_611ba788cae78 class="td_block_inner"><div class="td-related-row"><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.therwandan.com/kagames-supporters-for-his-vaccine-manufacturing-plant-have-increased-to-four-and-us3-5-million/" rel="bookmark" title="Kagame’s Supporters for his Vaccine Manufacturing Plant Have Increased to Four and US$3.5 Million"><img width="218" height="150" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2020/12/Skjermbilde-2020-12-23-kl.-06.17.48-218x150.png" srcset="https://www.therwandan.com/wp-content/uploads/2020/12/Skjermbilde-2020-12-23-kl.-06.17.48-218x150.png 218w, https://www.therwandan.com/wp-content/uploads/2020/12/Skjermbilde-2020-12-23-kl.-06.17.48-100x70.png 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Kagame’s Supporters for his Vaccine Manufacturing Plant Have Increased to Four and US$3.5 Million"/></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/kagames-supporters-for-his-vaccine-manufacturing-plant-have-increased-to-four-and-us3-5-million/" rel="bookmark" title="Kagame’s Supporters for his Vaccine Manufacturing Plant Have Increased to Four and US$3.5 Million">Kagame’s Supporters for his Vaccine Manufacturing Plant Have Increased to Four and US$3.5 Million</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.therwandan.com/kagame-says-his-banana-republic-is-consolidating-middle-income-status-from-which-it-will-move-to-an-upper-middle-income-level/" rel="bookmark" title="Kagame says his banana republic is consolidating middle-income status from which it will move to an upper-middle-income level"><img width="218" height="150" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2020/12/Skjermbilde-2020-12-23-kl.-06.17.48-218x150.png" srcset="https://www.therwandan.com/wp-content/uploads/2020/12/Skjermbilde-2020-12-23-kl.-06.17.48-218x150.png 218w, https://www.therwandan.com/wp-content/uploads/2020/12/Skjermbilde-2020-12-23-kl.-06.17.48-100x70.png 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Kagame says his banana republic is consolidating middle-income status from which it will move to an upper-middle-income level"/></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/kagame-says-his-banana-republic-is-consolidating-middle-income-status-from-which-it-will-move-to-an-upper-middle-income-level/" rel="bookmark" title="Kagame says his banana republic is consolidating middle-income status from which it will move to an upper-middle-income level">Kagame says his banana republic is consolidating middle-income status from which it will move to an upper-middle-income level</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.therwandan.com/rwanda-why-the-financial-intelligence-centre-was-set-up/" rel="bookmark" title="Rwanda: why the Financial Intelligence Centre was set up"><img width="218" height="150" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2021/08/FIC_logo-218x150.jpg" srcset="https://www.therwandan.com/wp-content/uploads/2021/08/FIC_logo-218x150.jpg 218w, https://www.therwandan.com/wp-content/uploads/2021/08/FIC_logo-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Rwanda: why the Financial Intelligence Centre was set up"/></a></div></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/rwanda-why-the-financial-intelligence-centre-was-set-up/" rel="bookmark" title="Rwanda: why the Financial Intelligence Centre was set up">Rwanda: why the Financial Intelligence Centre was set up</a></h3></div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_32_611ba788cae78" data-td_block_id="td_uid_32_611ba788cae78"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_32_611ba788cae78" data-td_block_id="td_uid_32_611ba788cae78"><i class="td-icon-font td-icon-menu-right"></i></a></div></div><div class="comments" id="comments"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">LEAVE A REPLY <small><a rel="nofollow" id="cancel-comment-reply-link" href="/kagame-is-giving-more-cash-to-the-english-football-club-arsenal-to-wear-a-rwanda-logo-on-their-shirt-sleeves/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.therwandan.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><div class="clearfix"></div><p class="comment-form-input-wrap td-form-comment"><textarea placeholder="Comment:" id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea></p><p class="comment-form-input-wrap td-form-author"> <span class="comment-req-wrap"> <input class="" id="author" name="author" placeholder="Name:" type="text" value="" size="30" /></span></p><p class="comment-form-input-wrap td-form-email"> <span class="comment-req-wrap"><input class="" id="email" name="email" placeholder="Email:" type="text" value="" size="30" /></span></p><p class="comment-form-input-wrap td-form-url"> <input class="" id="url" name="url" placeholder="Website:" type="text" value="" size="30" /></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='16895' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><input type="hidden" id="ct_checkjs_70efdf2ec9b086079795c442636b55fb" name="ct_checkjs" value="0" /><input type="hidden" id="ak_js" name="ak_js" value="61"/><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form></div></div></div></div><div class="td-pb-span4 td-main-sidebar" role="complementary"><div class="td-ss-main-sidebar"><div class="td-a-rec td-a-rec-id-custom_ad_4  "><div id="1586x300x600x309x_ADSLOT1" clickTrack="%%CLICK_URL_ESC%%"></div> <script type="text/javascript" async src="//served-by.pixfuture.com/www/delivery/headerbid.js" slotId="1586x300x600x309x_ADSLOT1"></script></div><div class="td_block_wrap td_block_social_counter td_block_widget td_uid_36_611ba788d5eac_rand td-pb-border-top"><style scoped>.td_uid_36_611ba788d5eac_rand .td_module_wrap:hover .entry-title a,
            .td_uid_36_611ba788d5eac_rand a.td-pulldown-filter-link:hover,
            .td_uid_36_611ba788d5eac_rand .td-subcat-item a:hover,
            .td_uid_36_611ba788d5eac_rand .td-subcat-item .td-cur-simple-item,
            .td_uid_36_611ba788d5eac_rand .td_quote_on_blocks,
            .td_uid_36_611ba788d5eac_rand .td-opacity-cat .td-post-category:hover,
            .td_uid_36_611ba788d5eac_rand .td-opacity-read .td-read-more a:hover,
            .td_uid_36_611ba788d5eac_rand .td-opacity-author .td-post-author-name a:hover,
            .td_uid_36_611ba788d5eac_rand .td-instagram-user a {
                color: #f44336;
            }

            .td_uid_36_611ba788d5eac_rand .td-next-prev-wrap a:hover,
            .td_uid_36_611ba788d5eac_rand .td-load-more-wrap a:hover {
                background-color: #f44336;
                border-color: #f44336;
            }

            .td_uid_36_611ba788d5eac_rand .block-title span,
            .td_uid_36_611ba788d5eac_rand .td-trending-now-title,
            .td_uid_36_611ba788d5eac_rand .block-title a,
            .td_uid_36_611ba788d5eac_rand .td-read-more a,
            .td_uid_36_611ba788d5eac_rand .td-weather-information:before,
            .td_uid_36_611ba788d5eac_rand .td-weather-week:before,
            .td_uid_36_611ba788d5eac_rand .td-subcat-dropdown:hover .td-subcat-more,
            .td_uid_36_611ba788d5eac_rand .td-exchange-header:before,
            .td_uid_36_611ba788d5eac_rand .td-post-category:hover {
                background-color: #f44336;
            }

            .td_uid_36_611ba788d5eac_rand .block-title {
                border-color: #f44336;
            }

            
            .td_uid_36_611ba788d5eac_rand .block-title span,
            .td_uid_36_611ba788d5eac_rand .td-trending-now-title,
            .td_uid_36_611ba788d5eac_rand .block-title a {
                color: #;
            }</style><h4 class="block-title"><span>FOLLOW US</span></h4><div class="td-social-list"><div class="td_social_type td-pb-margin-side td_social_facebook"><div class="td-social-box"><div class="td-sp td-sp-facebook"></div><span class="td_social_info">0</span><span class="td_social_info td_social_info_name">Fans</span><span class="td_social_button"><a href="https://www.facebook.com/therwandanamakuru">Like</a></span></div></div><div class="td_social_type td-pb-margin-side td_social_twitter"><div class="td-social-box"><div class="td-sp td-sp-twitter"></div><span class="td_social_info">3,823</span><span class="td_social_info td_social_info_name">Followers</span><span class="td_social_button"><a href="https://twitter.com/therwandaeditor">Follow</a></span></div></div><div class="td_social_type td-pb-margin-side td_social_youtube"><div class="td-social-box"><div class="td-sp td-sp-youtube"></div><span class="td_social_info">44,435</span><span class="td_social_info td_social_info_name">Subscribers</span><span class="td_social_button"><a href="https://www.youtube.com/channel/UCIeeam-RBIzjw21Hbw7p1iA">Subscribe</a></span></div></div></div></div><div class="td_block_wrap td_block_slide td_block_widget td_uid_37_611ba788d650e_rand td-pb-border-top"  data-td-block-uid="td_uid_37_611ba788d650e" ><style scoped>.td_uid_37_611ba788d650e_rand .td_module_wrap:hover .entry-title a,
            .td_uid_37_611ba788d650e_rand a.td-pulldown-filter-link:hover,
            .td_uid_37_611ba788d650e_rand .td-subcat-item a:hover,
            .td_uid_37_611ba788d650e_rand .td-subcat-item .td-cur-simple-item,
            .td_uid_37_611ba788d650e_rand .td_quote_on_blocks,
            .td_uid_37_611ba788d650e_rand .td-opacity-cat .td-post-category:hover,
            .td_uid_37_611ba788d650e_rand .td-opacity-read .td-read-more a:hover,
            .td_uid_37_611ba788d650e_rand .td-opacity-author .td-post-author-name a:hover,
            .td_uid_37_611ba788d650e_rand .td-instagram-user a {
                color: #de83f1;
            }

            .td_uid_37_611ba788d650e_rand .td-next-prev-wrap a:hover,
            .td_uid_37_611ba788d650e_rand .td-load-more-wrap a:hover {
                background-color: #de83f1;
                border-color: #de83f1;
            }

            .td_uid_37_611ba788d650e_rand .block-title span,
            .td_uid_37_611ba788d650e_rand .td-trending-now-title,
            .td_uid_37_611ba788d650e_rand .block-title a,
            .td_uid_37_611ba788d650e_rand .td-read-more a,
            .td_uid_37_611ba788d650e_rand .td-weather-information:before,
            .td_uid_37_611ba788d650e_rand .td-weather-week:before,
            .td_uid_37_611ba788d650e_rand .td-subcat-dropdown:hover .td-subcat-more,
            .td_uid_37_611ba788d650e_rand .td-exchange-header:before,
            .td_uid_37_611ba788d650e_rand .td-post-category:hover {
                background-color: #de83f1;
            }

            .td_uid_37_611ba788d650e_rand .block-title {
                border-color: #de83f1;
            }

            
            .td_uid_37_611ba788d650e_rand .block-title span,
            .td_uid_37_611ba788d650e_rand .td-trending-now-title,
            .td_uid_37_611ba788d650e_rand .block-title a {
                color: #ffffff;
            }</style><script>var block_td_uid_37_611ba788d650e = new tdBlock();
block_td_uid_37_611ba788d650e.id = "td_uid_37_611ba788d650e";
block_td_uid_37_611ba788d650e.atts = '{"limit":"10","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"RECENT POSTS","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"#de83f1","header_text_color":"#ffffff","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_block_widget td_uid_37_611ba788d650e_rand","el_class":"","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_37_611ba788d650e.td_column_number = "1";
block_td_uid_37_611ba788d650e.block_type = "td_block_slide";
block_td_uid_37_611ba788d650e.post_count = "10";
block_td_uid_37_611ba788d650e.found_posts = "4466";
block_td_uid_37_611ba788d650e.header_color = "#de83f1";
block_td_uid_37_611ba788d650e.ajax_pagination_infinite_stop = "";
block_td_uid_37_611ba788d650e.max_num_pages = "447";
tdBlocksArray.push(block_td_uid_37_611ba788d650e);</script><div class="td-block-title-wrap"><h4 class="block-title"><span>RECENT POSTS</span></h4></div><div id=td_uid_37_611ba788d650e class="td_block_inner"><div id="td_uid_38_611ba788d80b6" class="td-theme-slider iosSlider-col-1 td_mod_wrap"><div class="td-slider "><div id="td_uid_38_611ba788d80b6_item_0" class = "td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://www.therwandan.com/kagame-is-giving-more-cash-to-the-english-football-club-arsenal-to-wear-a-rwanda-logo-on-their-shirt-sleeves/" rel="bookmark" title="Kagame is giving more cash to the English Football Club, Arsenal, to wear a Rwanda logo on their shirt sleeves."><img width="324" height="400" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2021/08/kagame-arsenal-324x400.jpg" alt="" title="Kagame is giving more cash to the English Football Club, Arsenal, to wear a Rwanda logo on their shirt sleeves."/></a></div><div class="td-slide-meta"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/kagame-is-giving-more-cash-to-the-english-football-club-arsenal-to-wear-a-rwanda-logo-on-their-shirt-sleeves/" rel="bookmark" title="Kagame is giving more cash to the English Football Club, Arsenal, to wear a Rwanda logo on their shirt sleeves.">Kagame is giving more cash to the English Football Club, Arsenal, to wear a Rwanda logo on their shirt sleeves.</a></h3><div class="td-module-meta-info"><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-08-17T12:11:13+00:00" >August 17, 2021</time></span></div></div></div><div id="td_uid_38_611ba788d80b6_item_1" class = "td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://www.therwandan.com/advantages-of-gambling-at-bet365-on-mobile-devices/" rel="bookmark" title="Advantages of gambling at Bet365 on mobile devices"><img width="324" height="315" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2021/08/Skjermbilde-2021-08-17-kl.-13.14.09-324x315.png" alt="" title="Advantages of gambling at Bet365 on mobile devices"/></a></div><div class="td-slide-meta"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/advantages-of-gambling-at-bet365-on-mobile-devices/" rel="bookmark" title="Advantages of gambling at Bet365 on mobile devices">Advantages of gambling at Bet365 on mobile devices</a></h3><div class="td-module-meta-info"><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-08-17T11:15:33+00:00" >August 17, 2021</time></span></div></div></div><div id="td_uid_38_611ba788d80b6_item_2" class = "td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://www.therwandan.com/interpol-ambassador-gasana-eugene-richard-defeated-president-kagame-paul/" rel="bookmark" title="INTERPOL: Ambassador Gasana Eugène Richard defeated President Kagame Paul"><img width="324" height="400" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2021/08/Skjermbilde-2021-08-16-kl.-20.21.06-324x400.png" alt="" title="INTERPOL: Ambassador Gasana Eugène Richard defeated President Kagame Paul"/></a></div><div class="td-slide-meta"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/interpol-ambassador-gasana-eugene-richard-defeated-president-kagame-paul/" rel="bookmark" title="INTERPOL: Ambassador Gasana Eugène Richard defeated President Kagame Paul">INTERPOL: Ambassador Gasana Eugène Richard defeated President Kagame Paul</a></h3><div class="td-module-meta-info"><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-08-16T19:14:39+00:00" >August 16, 2021</time></span></div></div></div><div id="td_uid_38_611ba788d80b6_item_3" class = "td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://www.therwandan.com/the-new-association-of-genocide-survivors-and-the-fear-of-the-kigali-regime/" rel="bookmark" title="Igicumbi: the new association of genocide survivors and the fear of the Kigali regime "><img width="324" height="400" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2021/08/Skjermbilde-2021-08-01-kl.-19.53.29-324x400.png" alt="" title="Igicumbi: the new association of genocide survivors and the fear of the Kigali regime "/></a></div><div class="td-slide-meta"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/the-new-association-of-genocide-survivors-and-the-fear-of-the-kigali-regime/" rel="bookmark" title="Igicumbi: the new association of genocide survivors and the fear of the Kigali regime ">Igicumbi: the new association of genocide survivors and the fear of the Kigali regime </a></h3><div class="td-module-meta-info"><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-08-16T18:58:58+00:00" >August 16, 2021</time></span></div></div></div><div id="td_uid_38_611ba788d80b6_item_4" class = "td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://www.therwandan.com/kagames-bromance-with-dr-congos-rulers-in-about-mineral-wealth-rwandas-gold-exports-are-skyrocketing/" rel="bookmark" title="Kagame’s Bromance with DR Congo’s Rulers in About Mineral Wealth – Rwanda’s Gold Exports Are Skyrocketing"><img width="324" height="400" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2019/12/Kagame-tshisekedi1-324x400.jpg" alt="" title="Kagame’s Bromance with DR Congo’s Rulers in About Mineral Wealth – Rwanda’s Gold Exports Are Skyrocketing"/></a></div><div class="td-slide-meta"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/kagames-bromance-with-dr-congos-rulers-in-about-mineral-wealth-rwandas-gold-exports-are-skyrocketing/" rel="bookmark" title="Kagame’s Bromance with DR Congo’s Rulers in About Mineral Wealth – Rwanda’s Gold Exports Are Skyrocketing">Kagame’s Bromance with DR Congo’s Rulers in About Mineral Wealth – Rwanda’s Gold Exports Are Skyrocketing</a></h3><div class="td-module-meta-info"><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-08-16T13:28:28+00:00" >August 16, 2021</time></span></div></div></div><div id="td_uid_38_611ba788d80b6_item_5" class = "td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://www.therwandan.com/kagames-supporters-for-his-vaccine-manufacturing-plant-have-increased-to-four-and-us3-5-million/" rel="bookmark" title="Kagame’s Supporters for his Vaccine Manufacturing Plant Have Increased to Four and US$3.5 Million"><img width="324" height="400" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2020/12/Skjermbilde-2020-12-23-kl.-06.17.48-324x400.png" alt="" title="Kagame’s Supporters for his Vaccine Manufacturing Plant Have Increased to Four and US$3.5 Million"/></a></div><div class="td-slide-meta"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/kagames-supporters-for-his-vaccine-manufacturing-plant-have-increased-to-four-and-us3-5-million/" rel="bookmark" title="Kagame’s Supporters for his Vaccine Manufacturing Plant Have Increased to Four and US$3.5 Million">Kagame’s Supporters for his Vaccine Manufacturing Plant Have Increased to Four and US$3.5 Million</a></h3><div class="td-module-meta-info"><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-08-16T13:25:22+00:00" >August 16, 2021</time></span></div></div></div><div id="td_uid_38_611ba788d80b6_item_6" class = "td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://www.therwandan.com/tips-to-make-the-fashion-style-look-great-on-people/" rel="bookmark" title="Tips to make the fashion style look great on people"><img width="324" height="329" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2021/08/Skjermbilde-2021-08-16-kl.-13.33.57-324x329.png" alt="" title="Tips to make the fashion style look great on people"/></a></div><div class="td-slide-meta"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/tips-to-make-the-fashion-style-look-great-on-people/" rel="bookmark" title="Tips to make the fashion style look great on people">Tips to make the fashion style look great on people</a></h3><div class="td-module-meta-info"><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-08-16T11:34:52+00:00" >August 16, 2021</time></span></div></div></div><div id="td_uid_38_611ba788d80b6_item_7" class = "td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://www.therwandan.com/kagame-orders-the-english-football-club-arsenal-not-to-lose-games-%f0%9f%98%82/" rel="bookmark" title="Kagame Orders the English Football Club, Arsenal, Not to Lose Games &#x1f602;"><img width="324" height="400" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2018/05/President-Paul-Kagame...-324x400.jpg" alt="" title="Kagame Orders the English Football Club, Arsenal, Not to Lose Games &#x1f602;"/></a></div><div class="td-slide-meta"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/kagame-orders-the-english-football-club-arsenal-not-to-lose-games-%f0%9f%98%82/" rel="bookmark" title="Kagame Orders the English Football Club, Arsenal, Not to Lose Games &#x1f602;">Kagame Orders the English Football Club, Arsenal, Not to Lose Games &#x1f602;</a></h3><div class="td-module-meta-info"><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-08-14T07:47:46+00:00" >August 14, 2021</time></span></div></div></div><div id="td_uid_38_611ba788d80b6_item_8" class = "td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://www.therwandan.com/appeal-to-dutch-parliament-to-end-the-handing-over-of-political-refugees-to-the-rwandan-brutal-regime/" rel="bookmark" title="APPEAL TO DUTCH PARLIAMENT TO END THE HANDING OVER OF POLITICAL REFUGEES TO THE RWANDAN BRUTAL REGIME."><img width="324" height="400" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2021/02/RBB-324x400.jpg" alt="" title="APPEAL TO DUTCH PARLIAMENT TO END THE HANDING OVER OF POLITICAL REFUGEES TO THE RWANDAN BRUTAL REGIME."/></a></div><div class="td-slide-meta"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/appeal-to-dutch-parliament-to-end-the-handing-over-of-political-refugees-to-the-rwandan-brutal-regime/" rel="bookmark" title="APPEAL TO DUTCH PARLIAMENT TO END THE HANDING OVER OF POLITICAL REFUGEES TO THE RWANDAN BRUTAL REGIME.">APPEAL TO DUTCH PARLIAMENT TO END THE HANDING OVER OF POLITICAL REFUGEES TO THE RWANDAN BRUTAL REGIME.</a></h3><div class="td-module-meta-info"><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-08-12T20:04:43+00:00" >August 12, 2021</time></span></div></div></div><div id="td_uid_38_611ba788d80b6_item_9" class = "td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://www.therwandan.com/must-rwanda-continue-to-receive-belgian-aid/" rel="bookmark" title="Must Rwanda continue to receive Belgian aid?"><img width="200" height="300" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2015/12/filip.jpg" alt="" title="Must Rwanda continue to receive Belgian aid?"/></a></div><div class="td-slide-meta"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/must-rwanda-continue-to-receive-belgian-aid/" rel="bookmark" title="Must Rwanda continue to receive Belgian aid?">Must Rwanda continue to receive Belgian aid?</a></h3><div class="td-module-meta-info"><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-08-12T19:04:11+00:00" >August 12, 2021</time></span></div></div></div></div><i class = "td-icon-left prevButton"></i><i class = "td-icon-right nextButton"></i></div></div></div>  <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-custom_ad_2 "> <script type="text/javascript">var td_screen_width = window.innerWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-2768989567748188" data-ad-slot="7393339766"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-2768989567748188" data-ad-slot="7393339766"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:200px;height:200px" data-ad-client="ca-pub-2768989567748188" data-ad-slot="7393339766"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-2768989567748188" data-ad-slot="7393339766"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }</script> </div><div class="td_block_wrap td_block_slide td_block_widget td_uid_40_611ba788dedfa_rand td-pb-border-top"  data-td-block-uid="td_uid_40_611ba788dedfa" ><script>var block_td_uid_40_611ba788dedfa = new tdBlock();
block_td_uid_40_611ba788dedfa.id = "td_uid_40_611ba788dedfa";
block_td_uid_40_611ba788dedfa.atts = '{"limit":"20","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"49","category_ids":"","custom_title":"CARTOON","custom_url":"https:\/\/www.therwandan.com\/category\/news\/caricature\/","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"#","header_text_color":"#","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_block_widget td_uid_40_611ba788dedfa_rand","el_class":"","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_40_611ba788dedfa.td_column_number = "1";
block_td_uid_40_611ba788dedfa.block_type = "td_block_slide";
block_td_uid_40_611ba788dedfa.post_count = "20";
block_td_uid_40_611ba788dedfa.found_posts = "21";
block_td_uid_40_611ba788dedfa.header_color = "#";
block_td_uid_40_611ba788dedfa.ajax_pagination_infinite_stop = "";
block_td_uid_40_611ba788dedfa.max_num_pages = "2";
tdBlocksArray.push(block_td_uid_40_611ba788dedfa);</script><div class="td-block-title-wrap"><h4 class="block-title"><a href="https://www.therwandan.com/category/news/caricature/">CARTOON</a></h4></div><div id=td_uid_40_611ba788dedfa class="td_block_inner"><div id="td_uid_41_611ba788e3075" class="td-theme-slider iosSlider-col-1 td_mod_wrap"><div class="td-slider "><div id="td_uid_41_611ba788e3075_item_0" class = "td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://www.therwandan.com/the-new-image-of-francophonie/" rel="bookmark" title="The new image of Francophonie"><img width="324" height="400" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2018/10/Kagame-Macron-Mushikiwabo-324x400.jpg" alt="" title="The new image of Francophonie"/></a></div><div class="td-slide-meta"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/the-new-image-of-francophonie/" rel="bookmark" title="The new image of Francophonie">The new image of Francophonie</a></h3><div class="td-module-meta-info"><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-10-15T18:32:42+00:00" >October 15, 2018</time></span></div></div></div><div id="td_uid_41_611ba788e3075_item_1" class = "td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://www.therwandan.com/the-new-rwandan-penal-code/" rel="bookmark" title="The New Rwandan Penal Code"><img width="324" height="400" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2018/10/Rwandan-Penal-Code-324x400.jpg" alt="" title="The New Rwandan Penal Code"/></a></div><div class="td-slide-meta"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/the-new-rwandan-penal-code/" rel="bookmark" title="The New Rwandan Penal Code">The New Rwandan Penal Code</a></h3><div class="td-module-meta-info"><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-10-01T18:28:44+00:00" >October 1, 2018</time></span></div></div></div><div id="td_uid_41_611ba788e3075_item_2" class = "td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://www.therwandan.com/the-ambiguous-release-of-victoire-ingabire-umuhoza/" rel="bookmark" title="The ambiguous release of Victoire Ingabire Umuhoza"><img width="324" height="400" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2018/09/Ingabire-Matador-English-324x400.jpg" alt="" title="The ambiguous release of Victoire Ingabire Umuhoza"/></a></div><div class="td-slide-meta"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/the-ambiguous-release-of-victoire-ingabire-umuhoza/" rel="bookmark" title="The ambiguous release of Victoire Ingabire Umuhoza">The ambiguous release of Victoire Ingabire Umuhoza</a></h3><div class="td-module-meta-info"><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-09-21T09:21:50+00:00" >September 21, 2018</time></span></div></div></div><div id="td_uid_41_611ba788e3075_item_3" class = "td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://www.therwandan.com/is-victoire-ingabire-umuhoza-free/" rel="bookmark" title="Is Victoire Ingabire Umuhoza really Free?"><img width="324" height="400" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2018/09/Ingabire-English-324x400.jpg" alt="" title="Is Victoire Ingabire Umuhoza really Free?"/></a></div><div class="td-slide-meta"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/is-victoire-ingabire-umuhoza-free/" rel="bookmark" title="Is Victoire Ingabire Umuhoza really Free?">Is Victoire Ingabire Umuhoza really Free?</a></h3><div class="td-module-meta-info"><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-09-21T07:44:58+00:00" >September 21, 2018</time></span></div></div></div><div id="td_uid_41_611ba788e3075_item_4" class = "td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://www.therwandan.com/when-kagame-will-visit-rwanda/" rel="bookmark" title="When Kagame will visit Rwanda?"><img width="324" height="400" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2018/06/Kagame-Maguru-324x400.jpg" alt="" title="When Kagame will visit Rwanda?"/></a></div><div class="td-slide-meta"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/when-kagame-will-visit-rwanda/" rel="bookmark" title="When Kagame will visit Rwanda?">When Kagame will visit Rwanda?</a></h3><div class="td-module-meta-info"><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-06-15T20:24:45+00:00" >June 15, 2018</time></span></div></div></div><div id="td_uid_41_611ba788e3075_item_5" class = "td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://www.therwandan.com/james-musonis-passport-confiscated-by-presidential-guard/" rel="bookmark" title="James Musoni&#8217;s passport confiscated by presidential guard"><img width="324" height="400" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2018/03/Musoni-324x400.jpg" alt="" title="James Musoni&#8217;s passport confiscated by presidential guard"/></a></div><div class="td-slide-meta"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/james-musonis-passport-confiscated-by-presidential-guard/" rel="bookmark" title="James Musoni&#8217;s passport confiscated by presidential guard">James Musoni&#8217;s passport confiscated by presidential guard</a></h3><div class="td-module-meta-info"><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-03-19T16:59:38+00:00" >March 19, 2018</time></span></div></div></div><div id="td_uid_41_611ba788e3075_item_6" class = "td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://www.therwandan.com/genocide-a-terror-and-repression-weapon-in-the-hands-of-kagame/" rel="bookmark" title="Genocide: A Terror and repression weapon in the hands of Kagame"><img width="324" height="400" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2018/02/Kagame-Genocide-324x400.jpg" alt="" title="Genocide: A Terror and repression weapon in the hands of Kagame"/></a></div><div class="td-slide-meta"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/genocide-a-terror-and-repression-weapon-in-the-hands-of-kagame/" rel="bookmark" title="Genocide: A Terror and repression weapon in the hands of Kagame">Genocide: A Terror and repression weapon in the hands of Kagame</a></h3><div class="td-module-meta-info"><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-02-23T23:02:39+00:00" >February 23, 2018</time></span></div></div></div><div id="td_uid_41_611ba788e3075_item_7" class = "td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://www.therwandan.com/the-kagame-phantom-railways/" rel="bookmark" title="The Kagame Phantom Railways"><img width="324" height="400" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2018/01/Kagame-Train-324x400.jpg" alt="" title="The Kagame Phantom Railways"/></a></div><div class="td-slide-meta"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/the-kagame-phantom-railways/" rel="bookmark" title="The Kagame Phantom Railways">The Kagame Phantom Railways</a></h3><div class="td-module-meta-info"><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-01-17T09:01:38+00:00" >January 17, 2018</time></span></div></div></div><div id="td_uid_41_611ba788e3075_item_8" class = "td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://www.therwandan.com/rwanda-will-sarkozy-take-the-place-of-bill-clinton-and-tony-blair/" rel="bookmark" title="Rwanda: Will Sarkozy take the place of Bill Clinton and Tony Blair?"><img width="324" height="400" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2018/01/Sarkozy-Kagame-324x400.jpg" alt="" title="Rwanda: Will Sarkozy take the place of Bill Clinton and Tony Blair?"/></a></div><div class="td-slide-meta"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/rwanda-will-sarkozy-take-the-place-of-bill-clinton-and-tony-blair/" rel="bookmark" title="Rwanda: Will Sarkozy take the place of Bill Clinton and Tony Blair?">Rwanda: Will Sarkozy take the place of Bill Clinton and Tony Blair?</a></h3><div class="td-module-meta-info"><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-01-17T02:40:37+00:00" >January 17, 2018</time></span></div></div></div><div id="td_uid_41_611ba788e3075_item_9" class = "td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://www.therwandan.com/it-has-been-an-open-secret-in-zimbabwe-for-many-years-that-emmerson-mnangagwa-wanted-to-succeed-robert-mugabe-as-president/" rel="bookmark" title="It has been an open secret in Zimbabwe for many years that Emmerson Mnangagwa wanted to succeed Robert Mugabe as president."><img width="324" height="400" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2017/11/Mugabe-Emmerson-324x400.jpg" alt="" title="It has been an open secret in Zimbabwe for many years that Emmerson Mnangagwa wanted to succeed Robert Mugabe as president."/></a></div><div class="td-slide-meta"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/it-has-been-an-open-secret-in-zimbabwe-for-many-years-that-emmerson-mnangagwa-wanted-to-succeed-robert-mugabe-as-president/" rel="bookmark" title="It has been an open secret in Zimbabwe for many years that Emmerson Mnangagwa wanted to succeed Robert Mugabe as president.">It has been an open secret in Zimbabwe for many years that Emmerson Mnangagwa wanted to succeed Robert Mugabe as president.</a></h3><div class="td-module-meta-info"><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-11-23T00:03:31+00:00" >November 23, 2017</time></span></div></div></div><div id="td_uid_41_611ba788e3075_item_10" class = "td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://www.therwandan.com/kagame-gets-5000-for-each-refugee-deported-from-israel-to-rwanda/" rel="bookmark" title="Kagame gets 5000 $ for each refugee deported from Israel to Rwanda."><img width="324" height="400" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2017/11/171122_Marcmatabaro_2-324x400.jpg" alt="" title="Kagame gets 5000 $ for each refugee deported from Israel to Rwanda."/></a></div><div class="td-slide-meta"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/kagame-gets-5000-for-each-refugee-deported-from-israel-to-rwanda/" rel="bookmark" title="Kagame gets 5000 $ for each refugee deported from Israel to Rwanda.">Kagame gets 5000 $ for each refugee deported from Israel to Rwanda.</a></h3><div class="td-module-meta-info"><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-11-22T23:48:12+00:00" >November 22, 2017</time></span></div></div></div><div id="td_uid_41_611ba788e3075_item_11" class = "td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://www.therwandan.com/kagame-feels-that-he-should-be-elevated-to-nelson-mandela-or-mahatma-ghandis-status/" rel="bookmark" title="Kagame feels that he should be elevated to Nelson Mandela or Mahatma Ghandi&#8217;s status."><img width="324" height="400" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2017/11/Kagame-Mandela-na-Gandhi-324x400.jpg" alt="" title="Kagame feels that he should be elevated to Nelson Mandela or Mahatma Ghandi&#8217;s status."/></a></div><div class="td-slide-meta"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/kagame-feels-that-he-should-be-elevated-to-nelson-mandela-or-mahatma-ghandis-status/" rel="bookmark" title="Kagame feels that he should be elevated to Nelson Mandela or Mahatma Ghandi&#8217;s status.">Kagame feels that he should be elevated to Nelson Mandela or Mahatma Ghandi&#8217;s status.</a></h3><div class="td-module-meta-info"><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-11-12T17:11:30+00:00" >November 12, 2017</time></span></div></div></div><div id="td_uid_41_611ba788e3075_item_12" class = "td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://www.therwandan.com/i-stopped-listening-to-criminal-kagames-speeches-a-long-time-ago/" rel="bookmark" title="I stopped listening to Criminal Kagame’s speeches a long time ago"><img width="324" height="400" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2017/10/171031_Marcmatabaro_2-324x400.jpg" alt="" title="I stopped listening to Criminal Kagame’s speeches a long time ago"/></a></div><div class="td-slide-meta"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/i-stopped-listening-to-criminal-kagames-speeches-a-long-time-ago/" rel="bookmark" title="I stopped listening to Criminal Kagame’s speeches a long time ago">I stopped listening to Criminal Kagame’s speeches a long time ago</a></h3><div class="td-module-meta-info"><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-10-31T02:02:15+00:00" >October 31, 2017</time></span></div></div></div><div id="td_uid_41_611ba788e3075_item_13" class = "td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://www.therwandan.com/kagame-will-beg-for-cash/" rel="bookmark" title="The junta regime is at the cross roads, the country is facing its worst financial crisis in post genocide era."><img width="324" height="400" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2017/10/171021_Marcmatabaro-324x400.jpg" alt="" title="The junta regime is at the cross roads, the country is facing its worst financial crisis in post genocide era."/></a></div><div class="td-slide-meta"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/kagame-will-beg-for-cash/" rel="bookmark" title="The junta regime is at the cross roads, the country is facing its worst financial crisis in post genocide era.">The junta regime is at the cross roads, the country is facing its worst financial crisis in post genocide era.</a></h3><div class="td-module-meta-info"><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-10-21T12:51:23+00:00" >October 21, 2017</time></span></div></div></div><div id="td_uid_41_611ba788e3075_item_14" class = "td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://www.therwandan.com/kagame-the-ruler-hires-the-jet-from-criminal-kagame-the-businessman/" rel="bookmark" title="Kagame &#8211; the ruler hires the jet from criminal Kagame the businessman"><img width="324" height="400" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2017/10/Kagame-Convention-Centre-324x400.jpg" alt="" title="Kagame &#8211; the ruler hires the jet from criminal Kagame the businessman"/></a></div><div class="td-slide-meta"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/kagame-the-ruler-hires-the-jet-from-criminal-kagame-the-businessman/" rel="bookmark" title="Kagame &#8211; the ruler hires the jet from criminal Kagame the businessman">Kagame &#8211; the ruler hires the jet from criminal Kagame the businessman</a></h3><div class="td-module-meta-info"><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-10-21T12:44:06+00:00" >October 21, 2017</time></span></div></div></div><div id="td_uid_41_611ba788e3075_item_15" class = "td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://www.therwandan.com/is-it-diane-shima-rwigara-and-her-family-on-trial-or-kagame-and-his-courts-are-on-trial/" rel="bookmark" title="Is it Diane Shima Rwigara and her family on trial or Kagame and his Courts are on trial?"><img width="324" height="400" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2017/10/171016_Marcmatabaro_4-324x400.jpg" alt="" title="Is it Diane Shima Rwigara and her family on trial or Kagame and his Courts are on trial?"/></a></div><div class="td-slide-meta"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/is-it-diane-shima-rwigara-and-her-family-on-trial-or-kagame-and-his-courts-are-on-trial/" rel="bookmark" title="Is it Diane Shima Rwigara and her family on trial or Kagame and his Courts are on trial?">Is it Diane Shima Rwigara and her family on trial or Kagame and his Courts are on trial?</a></h3><div class="td-module-meta-info"><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-10-19T17:17:19+00:00" >October 19, 2017</time></span></div></div></div><div id="td_uid_41_611ba788e3075_item_16" class = "td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://www.therwandan.com/has-kagame-become-a-victim-of-his-relationship-with-the-clintons/" rel="bookmark" title="Has Kagame become a victim of his relationship with the Clintons?"><img width="324" height="400" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2017/10/Kagame-Trump-324x400.jpg" alt="" title="Has Kagame become a victim of his relationship with the Clintons?"/></a></div><div class="td-slide-meta"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/has-kagame-become-a-victim-of-his-relationship-with-the-clintons/" rel="bookmark" title="Has Kagame become a victim of his relationship with the Clintons?">Has Kagame become a victim of his relationship with the Clintons?</a></h3><div class="td-module-meta-info"><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-10-18T16:53:04+00:00" >October 18, 2017</time></span></div></div></div><div id="td_uid_41_611ba788e3075_item_17" class = "td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://www.therwandan.com/the-union-trade-centre-saga/" rel="bookmark" title="The Union Trade Centre Saga"><img width="324" height="400" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2017/10/Rujugiro-vs-Kagame-–-Kopi-324x400.jpg" alt="" title="The Union Trade Centre Saga"/></a></div><div class="td-slide-meta"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/the-union-trade-centre-saga/" rel="bookmark" title="The Union Trade Centre Saga">The Union Trade Centre Saga</a></h3><div class="td-module-meta-info"><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-10-16T12:42:49+00:00" >October 16, 2017</time></span></div></div></div><div id="td_uid_41_611ba788e3075_item_18" class = "td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://www.therwandan.com/adeline-rwigaras-holy-bible-has-been-confiscated/" rel="bookmark" title="Adeline Rwigara&#8217;s Holy Bible has been confiscated!"><img width="324" height="400" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2017/10/171014_Marcmatabaro-324x400.jpg" alt="" title="Adeline Rwigara&#8217;s Holy Bible has been confiscated!"/></a></div><div class="td-slide-meta"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/adeline-rwigaras-holy-bible-has-been-confiscated/" rel="bookmark" title="Adeline Rwigara&#8217;s Holy Bible has been confiscated!">Adeline Rwigara&#8217;s Holy Bible has been confiscated!</a></h3><div class="td-module-meta-info"><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-10-14T15:21:43+00:00" >October 14, 2017</time></span></div></div></div><div id="td_uid_41_611ba788e3075_item_19" class = "td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://www.therwandan.com/ange-kagame-in-the-steps-of-her-father/" rel="bookmark" title="Ange Kagame In the steps of her father?"><img width="324" height="400" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2017/10/Ange-Twitter-1-324x400.jpg" alt="" title="Ange Kagame In the steps of her father?"/></a></div><div class="td-slide-meta"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/ange-kagame-in-the-steps-of-her-father/" rel="bookmark" title="Ange Kagame In the steps of her father?">Ange Kagame In the steps of her father?</a></h3><div class="td-module-meta-info"><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-10-09T16:32:52+00:00" >October 9, 2017</time></span></div></div></div></div><i class = "td-icon-left prevButton"></i><i class = "td-icon-right nextButton"></i></div></div></div></div></div></div></div></div><div class="td-footer-wrapper td-footer-template-2"><div class="td-container"><div class="td-pb-row"><div class="td-pb-span12">  <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-footer_top "> <script type="text/javascript">var td_screen_width = window.innerWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:970px;height:90px" data-ad-client="ca-pub-2768989567748188" data-ad-slot="7393339766"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-2768989567748188" data-ad-slot="7393339766"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-2768989567748188" data-ad-slot="7393339766"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-2768989567748188" data-ad-slot="7393339766"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }</script> </div></div></div><div class="td-pb-row"><div class="td-pb-span4"><div class="td-footer-info"><div class="footer-logo-wrap"><a href="https://www.therwandan.com/"><img class="td-retina-data" src="https://www.therwandan.com/wp-content/uploads/2016/10/The-Rwandan-1.png" data-retina="https://www.therwandan.com/wp-content/uploads/2016/10/The-Rwandan-1.png" alt="" title=""/></a></div><div class="footer-text-wrap"></div><div class="footer-social-wrap td-social-style-2"></div></div></div><div class="td-pb-span4"><div class="td_block_wrap td_block_7 td_uid_43_611ba78901482_rand td-pb-border-top"  data-td-block-uid="td_uid_43_611ba78901482" ><script>var block_td_uid_43_611ba78901482 = new tdBlock();
block_td_uid_43_611ba78901482.id = "td_uid_43_611ba78901482";
block_td_uid_43_611ba78901482.atts = '{"limit":3,"sort":"popular","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"POPULAR POSTS","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_43_611ba78901482_rand","el_class":"","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_43_611ba78901482.td_column_number = "1";
block_td_uid_43_611ba78901482.block_type = "td_block_7";
block_td_uid_43_611ba78901482.post_count = "3";
block_td_uid_43_611ba78901482.found_posts = "4465";
block_td_uid_43_611ba78901482.header_color = "";
block_td_uid_43_611ba78901482.ajax_pagination_infinite_stop = "";
block_td_uid_43_611ba78901482.max_num_pages = "1489";
tdBlocksArray.push(block_td_uid_43_611ba78901482);</script><div class="td-block-title-wrap"><h4 class="block-title"><span>POPULAR POSTS</span></h4></div><div id=td_uid_43_611ba78901482 class="td_block_inner"><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.therwandan.com/a-response-to-a-recent-article-posted-in-the-financial-times-rwandas-leader-is-both-solomon-and-saddam/" rel="bookmark" title="A response to a recent article posted in the Financial Times : &#8220;Rwanda&#8217;s Leader is Both Solomon and Saddam&#8221;"><img width="100" height="70" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2017/10/171021_Marcmatabaro-100x70.jpg" srcset="https://www.therwandan.com/wp-content/uploads/2017/10/171021_Marcmatabaro-100x70.jpg 100w, https://www.therwandan.com/wp-content/uploads/2017/10/171021_Marcmatabaro-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="A response to a recent article posted in the Financial Times : &#8220;Rwanda&#8217;s Leader is Both Solomon and Saddam&#8221;"/></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/a-response-to-a-recent-article-posted-in-the-financial-times-rwandas-leader-is-both-solomon-and-saddam/" rel="bookmark" title="A response to a recent article posted in the Financial Times : &#8220;Rwanda&#8217;s Leader is Both Solomon and Saddam&#8221;">A response to a recent article posted in the Financial Times...</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2016-05-29T03:09:45+00:00" >May 29, 2016</time></span></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.therwandan.com/soon-criminal-paul-kagame-will-be-a-father-in-law-as-ange-kagame-finds-sweeter/" rel="bookmark" title="SOON, CRIMINAL PAUL KAGAME WILL BE A FATHER IN LAW, AS ANGE KAGAME FINDS SWEETER."><img width="100" height="70" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2018/01/Screenshot-at-jan.-10-18-13-42-100x70.png" srcset="https://www.therwandan.com/wp-content/uploads/2018/01/Screenshot-at-jan.-10-18-13-42-100x70.png 100w, https://www.therwandan.com/wp-content/uploads/2018/01/Screenshot-at-jan.-10-18-13-42-218x150.png 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="SOON, CRIMINAL PAUL KAGAME WILL BE A FATHER IN LAW, AS ANGE KAGAME FINDS SWEETER."/></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/soon-criminal-paul-kagame-will-be-a-father-in-law-as-ange-kagame-finds-sweeter/" rel="bookmark" title="SOON, CRIMINAL PAUL KAGAME WILL BE A FATHER IN LAW, AS ANGE KAGAME FINDS SWEETER.">SOON, CRIMINAL PAUL KAGAME WILL BE A FATHER IN LAW, AS...</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-01-10T17:22:33+00:00" >January 10, 2018</time></span></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.therwandan.com/kagame-gets-5000-for-each-refugee-deported-from-israel-to-rwanda/" rel="bookmark" title="Kagame gets 5000 $ for each refugee deported from Israel to Rwanda."><img width="100" height="70" class="entry-thumb" src="https://www.therwandan.com/wp-content/uploads/2017/11/171122_Marcmatabaro_2-100x70.jpg" srcset="https://www.therwandan.com/wp-content/uploads/2017/11/171122_Marcmatabaro_2-100x70.jpg 100w, https://www.therwandan.com/wp-content/uploads/2017/11/171122_Marcmatabaro_2-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Kagame gets 5000 $ for each refugee deported from Israel to Rwanda."/></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.therwandan.com/kagame-gets-5000-for-each-refugee-deported-from-israel-to-rwanda/" rel="bookmark" title="Kagame gets 5000 $ for each refugee deported from Israel to Rwanda.">Kagame gets 5000 $ for each refugee deported from Israel to...</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-11-22T23:48:12+00:00" >November 22, 2017</time></span></div></div></div></div></div></div></div><div class="td-pb-span4"><div class="td_block_wrap td_block_popular_categories td_uid_44_611ba7893fe1d_rand widget widget_categories td-pb-border-top"  data-td-block-uid="td_uid_44_611ba7893fe1d" ><h4 class="block-title"><span>POPULAR CATEGORY</span></h4><ul class="td-pb-padding-side"><li><a href="https://www.therwandan.com/category/opinion/">Opinion<span class="td-cat-no">656</span></a></li><li><a href="https://www.therwandan.com/category/news/rwanda/">Rwanda<span class="td-cat-no">576</span></a></li><li><a href="https://www.therwandan.com/category/news/">News<span class="td-cat-no">494</span></a></li><li><a href="https://www.therwandan.com/category/analysis/">Analysis<span class="td-cat-no">436</span></a></li><li><a href="https://www.therwandan.com/category/country/economy/">Economy<span class="td-cat-no">427</span></a></li><li><a href="https://www.therwandan.com/category/news/great-lakes/">Great lakes<span class="td-cat-no">402</span></a></li><li><a href="https://www.therwandan.com/category/news/africa/">Africa<span class="td-cat-no">358</span></a></li><li><a href="https://www.therwandan.com/category/news/world/">World<span class="td-cat-no">307</span></a></li><li><a href="https://www.therwandan.com/category/politics/press-release/">Press Release<span class="td-cat-no">237</span></a></li></ul></div></div></div></div></div><div class="td-sub-footer-container"><div class="td-container"><div class="td-pb-row"><div class="td-pb-span7 td-sub-footer-menu"></div><div class="td-pb-span5 td-sub-footer-copy"> &copy; Copyright 2012-2020- The Rwandan - All Rights Reserved</div></div></div></div></div> <script type="text/javascript" >window.addEventListener('DOMContentLoaded', function () {
					setTimeout(function(){
						if( document.querySelectorAll('[name^=ct_checkjs]').length > 0 ) {
			                apbct_public_sendAJAX(
			                    { action: 'apbct_js_keys__get' },
			                    { callback: apbct_js_keys__set_input_value, apbct_ajax: 1 }
			                );
			            }
					},0)					    
				});</script> <script type="text/javascript">var sbiajaxurl = "https://www.therwandan.com/wp-admin/admin-ajax.php";</script> <div class="td-container"><script data-ad-client="ca-pub-2768989567748188" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script type="text/javascript">window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u, i) {
    if (!document.getElementById(i)){
      e.async = 1;
      e.src = u;
      e.id = i;
      f.parentNode.insertBefore(e, f);
    }
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/therwandan/loader.js',
  'tb_loader_script');
  if(window.performance && typeof window.performance.mark == 'function')
    {window.performance.mark('tbl_ic');}</script> <script type="text/javascript">window._taboola = window._taboola || [];
  _taboola.push({flush: true});</script> <script async custom-element="amp-auto-ads"
        src="https://cdn.ampproject.org/v0/amp-auto-ads-0.1.js"></script> <amp-auto-ads type="adsense"
 data-ad-client="ca-pub-2768989567748188"> </amp-auto-ads> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-2768989567748188",
          enable_page_level_ads: true
     });</script> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle = window.adsbygoogle || []).push({ google_ad_client: "ca-pub-2768989567748188", enable_page_level_ads: true });</script></div><script type='text/javascript' src='https://www.therwandan.com/wp-content/themes/Newspaperbk/js/tagdiv_theme.js' id='td-site-js'></script> <script type='text/javascript' src='https://www.therwandan.com/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script> <script type='text/javascript' src='https://www.therwandan.com/wp-content/plugins/youtube-embed-plus/scripts/fitvids.min.js' id='__ytprefsfitvids__-js'></script> <script type='text/javascript' src='https://www.therwandan.com/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>  <script type="text/javascript">jQuery(document).ready(function(){
jQuery('.td_social_facebook .td_social_info').first().html('13136');
  
});</script>    <script>jQuery(document).ready(function() {
    jQuery("#td_uid_38_611ba788d80b6").iosSlider({
        snapToChildren: true,
        desktopClickDrag: true,
        keyboardControls: false,
        responsiveSlideContainer: true,
        responsiveSlides: true,
        
            autoSlide: true,
            autoSlideTimer: 3000,
            

        infiniteSlider: true,
        navPrevSelector: jQuery("#td_uid_38_611ba788d80b6 .prevButton"),
        navNextSelector: jQuery("#td_uid_38_611ba788d80b6 .nextButton")
        ,
                //onSliderLoaded : td_resize_normal_slide,
                //onSliderResize : td_resize_normal_slide_and_update
    });
});
    

jQuery(document).ready(function() {
    jQuery("#td_uid_41_611ba788e3075").iosSlider({
        snapToChildren: true,
        desktopClickDrag: true,
        keyboardControls: false,
        responsiveSlideContainer: true,
        responsiveSlides: true,
        
            autoSlide: true,
            autoSlideTimer: 3000,
            

        infiniteSlider: true,
        navPrevSelector: jQuery("#td_uid_41_611ba788e3075 .prevButton"),
        navNextSelector: jQuery("#td_uid_41_611ba788e3075 .nextButton")
        ,
                //onSliderLoaded : td_resize_normal_slide,
                //onSliderResize : td_resize_normal_slide_and_update
    });
});
    

                jQuery().ready(function jQuery_ready() {
                    tdAjaxCount.tdGetViewsCountsAjax("post","[16895]");
                });
            

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://www.therwandan.com/wp-content/themes/Newspaperbk/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://www.therwandan.com/wp-content/themes/Newspaperbk';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();</script> <div id="cookie-notice" role="banner" class="cookie-notice-hidden cookie-revoke-hidden cn-position-bottom" aria-label="Cookie Notice" style="background-color: rgba(0,0,0,1);"><div class="cookie-notice-container" style="color: #fff;"><span id="cn-notice-text" class="cn-text-container">We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.</span><span id="cn-notice-buttons" class="cn-buttons-container"><a href="#" id="cn-accept-cookie" data-cookie-set="accept" class="cn-set-cookie cn-button bootstrap button" aria-label="Ok">Ok</a></span><a href="javascript:void(0);" id="cn-close-notice" data-cookie-set="accept" class="cn-close-icon" aria-label="Ok"></a></div></div></body></html>
<!--
Performance optimized by W3 Total Cache. Learn more: https://www.boldgrid.com/w3-total-cache/

Object Caching 754/761 objects using disk
Page Caching using disk: enhanced 

Served from: www.therwandan.com @ 2021-08-17 12:11:53 by W3 Total Cache
-->